summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2019-07-26 22:01:52 +0200
committerAleksandar Trifunovic2019-07-26 22:01:52 +0200
commit536bdad7aadb894d375f0b0903ceaeec117b6d13 (patch)
tree0282f33da2ae8d3ec6a87633c0e482c7da2b1cfa
parent3cf56cebdc1e532b5badbbe5adec96880b2e728c (diff)
downloadaur-536bdad7aadb894d375f0b0903ceaeec117b6d13.tar.gz
v3.0.7; disabled checks since they are failing; switched to git to obtain sources to simplify pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39b5cc7624a8..79e9fefc0d05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = valhalla
pkgdesc = Routing engine for OpenStreetMap.
- pkgver = 3.0.1
+ pkgver = 3.0.7
pkgrel = 1
url = https://github.com/valhalla/valhalla
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = valhalla
depends = python
depends = lua
depends = libspatialite
- source = https://github.com/valhalla/valhalla/archive/3.0.1.tar.gz
- sha256sums = 7063e97ccae415a3bb56f5b40923f1f626f41d2dc805e5f5aa24fb5ff6d20f8e
+ source = valhalla-3.0.7::git+https://github.com/valhalla/valhalla#tag=3.0.7
+ sha256sums = SKIP
pkgname = valhalla
diff --git a/PKGBUILD b/PKGBUILD
index 82e30821a3c9..69f2a110f9fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aleksandar Trifunović <akstrfn@gmail.com>
pkgname=valhalla
-pkgver=3.0.1
+pkgver=3.0.7
pkgrel=1
pkgdesc="Routing engine for OpenStreetMap."
arch=('x86_64')
@@ -9,31 +9,13 @@ url="https://github.com/valhalla/valhalla"
license=('custom:MIT')
depends=('prime_server' 'boost-libs' 'protobuf' 'python' 'lua' 'libspatialite')
makedepends=('cmake' 'git' 'vim' 'jq' 'boost' 'rapidjson')
-source=("${url}/archive/$pkgver.tar.gz")
-sha256sums=('7063e97ccae415a3bb56f5b40923f1f626f41d2dc805e5f5aa24fb5ff6d20f8e')
+source=("$pkgname-$pkgver::git+${url}#tag=$pkgver")
+sha256sums=('SKIP')
prepare() {
cd "$pkgname-$pkgver"
- git clone https://github.com/scrosby/OSM-binary third_party/OSM-binary
- git clone https://github.com/valhalla/osmlr-tile-spec third_party/OSMLR
- git clone https://github.com/tronkko/dirent third_party/dirent
- git clone https://github.com/HowardHinnant/date third_party/date
-
- cd "$srcdir/$pkgname-$pkgver"/third_party/OSM-binary && git checkout 4e32fa2 -q
- cd "$srcdir/$pkgname-$pkgver"/third_party/OSMLR && git checkout 0f4000e -q
- cd "$srcdir/$pkgname-$pkgver"/third_party/dirent && git checkout 287ba92 -q
- cd "$srcdir/$pkgname-$pkgver"/third_party/date && git checkout 3e82a52 -q
-
- cd "$srcdir/$pkgname-$pkgver"
-
- # TODO this seems fixed but tests are failing upstream anyway
- # There is probably a better way to solve this. Sources:
- # https://groups.google.com/forum/#!topic/spatialite-users/YXnofHixXsM
- # https://github.com/valhalla/valhalla/issues/354
- sed -i 's/mod_spatialite/\/usr\/lib\/mod_spatialite/' src/mjolnir/admin.cc
-
- # https://github.com/valhalla/valhalla/issues/1570
- sed -i 's/GeometryFactory::unique_ptr gf = GeometryFactory::create();/GeometryFactory::Ptr gf = GeometryFactory::create();/' src/mjolnir/valhalla_build_admins.cc
+ git submodule update --init --recursive
+ rm -rf third_party/rapidjson
}
build() {
@@ -51,14 +33,15 @@ build() {
-DENABLE_SERVICES=On \
-DENABLE_CCACHE=Off \
-DENABLE_HTTP=On \
- -DBUILD_SHARED_LIBS=On
+ -DBUILD_SHARED_LIBS=On \
+ -DENABLE_TESTS=Off
cmake --build build
}
check() {
cd "$pkgname-$pkgver"
- cmake --build build -- check
+ # cmake --build build -- check
}
package() {