aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI Jack2015-08-31 14:02:54 -0400
committerGI Jack2015-08-31 14:02:54 -0400
commit536d184663daac1bfc8afaa16710fff7321c4b6b (patch)
tree5b8df3c2df1c7be6fccad1b22dc5ddfffa2506b4
downloadaur-536d184663daac1bfc8afaa16710fff7321c4b6b.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
-rw-r--r--README10
-rw-r--r--live_firewire24
-rw-r--r--live_mmc22
-rw-r--r--live_usb24
6 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d454c525e308
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mkinitcpio-liveusb-units
+ pkgdesc = mkinitcpio minimal block hooks for live usb sticks
+ pkgver = 1
+ pkgrel = 2
+ url = http://archlinux.org
+ arch = any
+ license = GPLv3
+ depends = mkinitcpio>=0.12
+ source = live_usb
+ source = live_mmc
+ source = live_firewire
+ md5sums = fe23d065b1232be3e73ae94b3e619acf
+ md5sums = b3bd45266897d51e43e4e747793e54b4
+ md5sums = 47331e58b269d9a6b955fcfbc3855f89
+ sha1sums = 1c925edb76ed9ed0b6c9949e7589757b5bab17c5
+ sha1sums = c28c3a42d34762adf799dcea69aa484f86b2781e
+ sha1sums = 3178105ed08fe5b76b6d93006d5fab7117c48df5
+
+pkgname = mkinitcpio-liveusb-units
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cbf739e393e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+pkgname=mkinitcpio-liveusb-units
+pkgver=1
+pkgrel=2
+pkgdesc="mkinitcpio minimal block hooks for live usb sticks"
+arch=('any')
+license=('GPLv3')
+url=('http://archlinux.org')
+depends=('mkinitcpio>=0.12')
+source=('live_usb' 'live_mmc' 'live_firewire')
+md5sums=('fe23d065b1232be3e73ae94b3e619acf'
+ 'b3bd45266897d51e43e4e747793e54b4'
+ '47331e58b269d9a6b955fcfbc3855f89')
+sha1sums=('1c925edb76ed9ed0b6c9949e7589757b5bab17c5'
+ 'c28c3a42d34762adf799dcea69aa484f86b2781e'
+ '3178105ed08fe5b76b6d93006d5fab7117c48df5')
+
+package() {
+ install -dm755 "${pkgdir}/usr/lib/initcpio/install"
+ install -m644 "${srcdir}/live_firewire" "${pkgdir}/usr/lib/initcpio/install/live_firewire"
+ install -m644 "${srcdir}/live_usb" "${pkgdir}/usr/lib/initcpio/install/live_usb"
+ install -m644 "${srcdir}/live_mmc" "${pkgdir}/usr/lib/initcpio/install/live_mmc"
+}
+
diff --git a/README b/README
new file mode 100644
index 000000000000..aabbe544199b
--- /dev/null
+++ b/README
@@ -0,0 +1,10 @@
+WHAT - These are mkinitcpio book hooks derived from the "block" hook, which is the new catch all, for all block devices. MMC, USB, and Firewire have been taken out and repacked invidually into their own hooks, meant to be used one at a time, as it was before.
+
+WHY - using "block" as opposed to only using USB increases the boot time, and added some ambiguity over which device got to be /dev/sda. The amount of boot time that was increased by the move was only 3 seconds. Considering previous boot time was around 26 seconds, its more than a %10 increase.
+
+If you need other drivers, just use block. This is specificly for booting live USB sticks faster. If your NOT using a Live USB stick SPECIFICLY(or firewire?), you don't need this package.
+
+It should also be noted that most mmc flash card readers are USB and only need USB drivers.(cell phones, and embedded devices use mmc when booting natively, your computer uses usb when connecting to the cellphone)
+
+HOW - after installing you may use the live_firewire, live_usb and live_mmc HOOKS= in mkinitcpio.conf.
+
diff --git a/live_firewire b/live_firewire
new file mode 100644
index 000000000000..d8c7d8f8a393
--- /dev/null
+++ b/live_firewire
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+build() {
+ local filter
+ local -A blockdevs
+ blockdevs+=(['usb_storage?']=1 ['sd_mod?']=1 ['sr_mod?']=1)
+ add_checked_modules 'drivers/usb/storage/ums-*'
+ fi
+
+ firewire
+ if add_checked_modules '/drivers/firewire/'; then
+ blockdevs+=(['firewire-sbp2?']=1 ['sd_mod?']=1 ['sr_mod?']=1)
+ fi
+}
+
+help() {
+ cat <<HELPEOF
+This hook loads the necessary modules for most block devices using firewire. Detection will take place at runtime. To minimize
+the modules in the image, add the autodetect hook too.
+HELPEOF
+}
+
+# vim: set ft=sh ts=4 sw=4 et:
+
diff --git a/live_mmc b/live_mmc
new file mode 100644
index 000000000000..7783489567de
--- /dev/null
+++ b/live_mmc
@@ -0,0 +1,22 @@
+#!/bin/bash
+
+build() {
+ local filter
+ local -A blockdevs
+
+ mmc
+ if add_checked_modules '/mmc'; then
+ blockdevs+=(['tifm_7xx1?']=1 ['mmc_block?']=1)
+ fi
+ map add_module "${!blockdevs[@]}"
+}
+
+help() {
+ cat <<HELPEOF
+This hook loads the necessary modules for most block devices using mmc. Detection will take place at runtime. To minimize
+the modules in the image, add the autodetect hook too.
+HELPEOF
+}
+
+# vim: set ft=sh ts=4 sw=4 et:
+
diff --git a/live_usb b/live_usb
new file mode 100644
index 000000000000..edbbae85363b
--- /dev/null
+++ b/live_usb
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+build() {
+ local filter
+ local -A blockdevs
+
+ # usb
+ if add_checked_modules -f '(_cs|sl811_hcd|isp116x_hcd)' '/usb/host'; then
+ blockdevs+=(['usb_storage?']=1 ['sd_mod?']=1 ['sr_mod?']=1)
+ add_checked_modules 'drivers/usb/storage/ums-*'
+ fi
+
+ map add_module "${!blockdevs[@]}"
+}
+
+help() {
+ cat <<HELPEOF
+This hook loads the necessary modules for usb block devices. Detection will take place at runtime. To minimize
+the modules in the image, add the autodetect hook too.
+HELPEOF
+}
+
+# vim: set ft=sh ts=4 sw=4 et:
+