summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Polishchuck2017-04-11 01:19:19 +0300
committerMaxim Polishchuck2017-04-11 01:20:21 +0300
commit53ab95b069f6887415828a37a0d1ad35f61e67ee (patch)
treeefff510f43e9b72578834e3e99735da63bb1714c
downloadaur-53ab95b069f6887415828a37a0d1ad35f61e67ee.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rwxr-xr-xlauncher-ovito.sh3
-rwxr-xr-xlauncher-ovitos.sh3
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09382d6b94c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 5.0.1
+# Mon Apr 10 22:18:04 UTC 2017
+pkgbase = ovito-opt
+ pkgdesc = A scientific visualization and analysis software for atomistic simulation data.
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = http://www.ovito.org
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = python
+ depends = qt5-svg
+ depends = ffmpeg2.8
+ conflicts = ovito
+ conflicts = ovito-git
+ source = http://www.ovito.org/download/2.7.0/ovito-2.7.0-x86_64.tar.gz
+ source = launcher-ovito.sh
+ source = launcher-ovitos.sh
+ md5sums = f8f5685f0d7e13a9f0af96308fa16499
+ md5sums = 2b86c33c121e442ee443168e6414cc2f
+ md5sums = a7e384fcc9ed17cf85205945336a5f49
+
+pkgname = ovito-opt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f32b1a0b846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Maxim Polishchuck <mpolishchuck[at]gmail[dot]com>
+_pkgname=ovito
+pkgname=ovito-opt
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="A scientific visualization and analysis software for atomistic simulation data."
+url="http://www.ovito.org"
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('python' 'qt5-svg' 'ffmpeg2.8')
+conflicts=('ovito' 'ovito-git')
+md5sums=(
+ ''
+ '2b86c33c121e442ee443168e6414cc2f'
+ 'a7e384fcc9ed17cf85205945336a5f49'
+)
+source=(
+ "http://www.ovito.org/download/$pkgver/${_pkgname}-$pkgver-$CARCH.tar.gz"
+ 'launcher-ovito.sh'
+ 'launcher-ovitos.sh'
+)
+
+if [[ $CARCH = i686 ]];then
+ md5sums[0]='6abf21ec650f5298bca20b2eba09645d'
+else
+ md5sums[0]='f8f5685f0d7e13a9f0af96308fa16499'
+fi
+
+package() {
+ cd ${_pkgname}-${pkgver}-$CARCH
+ install -d ${pkgdir}/opt/ovito
+ cp -dpr --no-preserve=ownership ./* ${pkgdir}/opt/ovito
+ # fix libGL library conflict errors
+ rm -r ${pkgdir}/opt/ovito/lib/ovito/libstdc++.so.{6,6.0.18}
+
+ install -Dm755 ${srcdir}/launcher-ovito.sh ${pkgdir}/usr/bin/ovito
+ install -Dm755 ${srcdir}/launcher-ovitos.sh ${pkgdir}/usr/bin/ovitos
+}
diff --git a/launcher-ovito.sh b/launcher-ovito.sh
new file mode 100755
index 000000000000..ae5c0aa2338e
--- /dev/null
+++ b/launcher-ovito.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /opt/ovito/bin/ovito $*
diff --git a/launcher-ovitos.sh b/launcher-ovitos.sh
new file mode 100755
index 000000000000..8c8afaa39436
--- /dev/null
+++ b/launcher-ovitos.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /opt/ovito/bin/ovitos $*