summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-08-14 11:46:49 -0400
committerSolomon Choina2020-08-14 11:46:49 -0400
commit53b4cacb93464446578c2862ff2c8c7684d01625 (patch)
treea2db671e17c856ca18abd588926ab12ce59bffac
parent3274b244f84b56109bf3c79b2aee48e27ade811e (diff)
downloadaur-53b4cacb93464446578c2862ff2c8c7684d01625.tar.gz
nicer pkgver and PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
2 files changed, 8 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 563b44bbfcfd..9a0513c7fe06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Mar 27 09:54:07 UTC 2018
pkgbase = switchboard-plug-about-git
pkgdesc = Switchboard About Plug
- pkgver = r664.badcac9
+ pkgver = 2.6.3.r46.g1bfe45b
pkgrel = 1
url = https://github.com/elementary/switchboard-plug-about
arch = x86_64
@@ -18,6 +16,7 @@ pkgbase = switchboard-plug-about-git
depends = gtk3
depends = libgee
depends = libswitchboard-2.0.so
+ depends = libgtop
provides = switchboard-plug-about
conflicts = switchboard-plug-about
source = git+https://github.com/elementary/switchboard-plug-about.git
diff --git a/PKGBUILD b/PKGBUILD
index f1f5de8311dd..4ec4bb552680 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-about-git
-pkgver=r664.badcac9
+pkgver=2.6.3.r46.g1bfe45b
pkgrel=1
pkgdesc='Switchboard About Plug'
arch=('x86_64')
@@ -9,7 +9,7 @@ url='https://github.com/elementary/switchboard-plug-about'
license=('GPL3')
groups=('pantheon-unstable')
depends=('glib2' 'glibc' 'gtk3' 'libgee'
- 'libswitchboard-2.0.so')
+ 'libswitchboard-2.0.so' 'libgtop' )
makedepends=('git' 'granite-git' 'meson' 'switchboard-git' 'vala')
provides=('switchboard-plug-about')
conflicts=('switchboard-plug-about')
@@ -19,27 +19,16 @@ sha256sums=('SKIP')
pkgver() {
cd switchboard-plug-about
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd build
-
- arch-meson ../switchboard-plug-about
- ninja
+ arch-meson switchboard-plug-about build
+ ninja -C build
}
package() {
- cd build
-
- DESTDIR="${pkgdir}" ninja install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: