summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2021-08-24 17:47:23 +0200
committerL.G. Sarmiento2021-08-24 17:47:23 +0200
commit53bd43d39167c908edfcf563d208c4940bd352e7 (patch)
tree681ae7cc90c1504337c1eb6cd277867ad9849236
parent6798110b4b8b00d0142953972114408d04ea724d (diff)
downloadaur-53bd43d39167c908edfcf563d208c4940bd352e7.tar.gz
/usr/go4login changed location
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 152a7ba116ef..8e585efa5417 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Aug 24 13:28:59 UTC 2021
+# Tue Aug 24 15:47:00 UTC 2021
pkgbase = go4
pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
pkgver = 6.1.2
@@ -13,7 +13,7 @@ pkgbase = go4
depends = hdf5
conflicts = mbseventapi
source = http://web-docs.gsi.de/~go4/download/go4-6.1.2.tar.gz
- sha256sums = 12312bc346f911c27cfd3b13e7b66e6e4c5f596029d339b5a6a1e9cd7cc70775
+ md5sums = c30e2d9e1108550e6a0330a81e9a3369
pkgname = go4
diff --git a/PKGBUILD b/PKGBUILD
index 1648beb06167..4469a54c352c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,13 +13,33 @@ conflicts=('mbseventapi')
url="https://www.gsi.de/en/work/research/experiment_electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
-
-sha256sums=('12312bc346f911c27cfd3b13e7b66e6e4c5f596029d339b5a6a1e9cd7cc70775')
+md5sums=('c30e2d9e1108550e6a0330a81e9a3369')
prepare() {
unset GO4SYS
+ #
+ # Most files created at the end of CMakeLists.txt end up in weird locations.
+ # for now it works... this will be fixed in a new release
+ #
+ # # ================== Copy files, create old support files ==========
+ #
+ # /usr/Go4License.txt --> /usr/share/licenses/go4/Go4License.txt
+ # /usr/README.txt --> /usr/share/doc/{pkg}
+ # /usr/CHANGES.txt --> /usr/share/doc/{pkg}
+ #
+ # /usr/go4login --> /usr/bin/go4login
+ #
+ #
+ # /usr/etc/ --> /etc/{pkg}
+ # /usr/docs/ --> /usr/share/doc/{pkg}
+ # /usr/icons --> /usr/share/{pkg}/icons
+ # /usr/html --> /usr/share/doc/{pkg}/html
+ # /usr/macros --> /usr/share/{pkg}/macros
+ # /usr/python --> /usr/share/{pkg}/python
+ #
+
}
build() {
@@ -67,7 +87,7 @@ package() {
cat <<- EOF > ${srcdir}/go4.sh
# source go4login script
- source /usr/bin/go4login
+ source /usr/go4login
# If ROOT_INCLUDE_PATH already exists, then add Go4 to it, otherwise do nothing
export ROOT_INCLUDE_PATH=\${ROOT_INCLUDE_PATH:+\$ROOT_INCLUDE_PATH:/usr/include/go4}