summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-20 23:58:38 -0800
committerxiota2023-12-20 23:58:38 -0800
commit53e923fd97dbf1c71fc47e2f242873d82bbb1216 (patch)
treefda1d4f8ac4aad7fc7fa4c21819e28302bc6d07c
parent8dd5e6896bac3484ee9792dd89041866db3dffd8 (diff)
downloadaur-53e923fd97dbf1c71fc47e2f242873d82bbb1216.tar.gz
5.0.r20822: update provides/conflicts
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD36
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5651e7b7c345..9667172c8e11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-debugfast-git
pkgdesc = A Gamecube / Wii / Triforce emulator
- pkgver = 5.0.r20613.g003872d7dd
+ pkgver = 5.0.r20822.g70b7a59456
pkgrel = 1
url = https://github.com/dolphin-emu/dolphin
arch = x86_64
@@ -43,7 +43,11 @@ pkgbase = dolphin-emu-debugfast-git
depends = zstd
optdepends = pulseaudio: PulseAudio backend
provides = dolphin-emu
+ provides = dolphin-emu-nogui
+ provides = dolphin-emu-tool
conflicts = dolphin-emu
+ conflicts = dolphin-emu-nogui
+ conflicts = dolphin-emu-tool
options = !emptydirs
options = !lto
source = dolphin-emu::git+https://github.com/dolphin-emu/dolphin.git
diff --git a/PKGBUILD b/PKGBUILD
index d1420222cd43..44427d3fe06b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,24 +7,18 @@
# options
: ${_debugfast:=false}
-: ${_avx_build:=false}
-: ${_pkgtype:=debugfast-git}
+: ${_build_debugfast:=true}
+: ${_build_avx:=false}
+: ${_build_git:=true}
-
-if [[ "${_avx_build::1}" == "t" ]] ; then
- if [ "${_pkgtype: -4}" == "-git" ] ; then
- _pkgtype="${_pkgtype%-*}-avx-${_pkgtype##*-}"
- elif [ "${_pkgtype::1}" == "g" ] ; then
- _pkgtype="avx-$_pkgtype"
- else
- _pkgtype+="-avx"
- fi
-fi
+[[ "${_build_debugfast::1}" == "t" ]] && _pkgtype+="-debugfast"
+[[ "${_build_avx::1}" == "t" ]] && _pkgtype+="-avx"
+[[ "${_build_git::1}" == "t" ]] && _pkgtype+="-git"
# basic info
_pkgname="dolphin-emu"
-pkgname="$_pkgname${_pkgtype:+-$_pkgtype}"
-pkgver=5.0.r20613.g003872d7dd
+pkgname="$_pkgname${_pkgtype:-}"
+pkgver=5.0.r20822.g70b7a59456
pkgrel=1
pkgdesc='A Gamecube / Wii / Triforce emulator'
arch=(x86_64)
@@ -181,8 +175,16 @@ _main_stable() {
_main_git() {
url="${_url:?}"
- provides=("$_pkgname")
- conflicts=("$_pkgname")
+ provides=(
+ 'dolphin-emu'
+ 'dolphin-emu-nogui'
+ 'dolphin-emu-tool'
+ )
+ conflicts=(
+ 'dolphin-emu'
+ 'dolphin-emu-nogui'
+ 'dolphin-emu-tool'
+ )
_pkgsrc="$_pkgname"
source=("$_pkgname"::"git+$url.git")
@@ -218,7 +220,7 @@ prepare() {
}
build() {
- if [[ "${_avx_build::1}" == "t" ]] ; then
+ if [[ "${_build_avx::1}" == "t" ]] ; then
export CFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
export CXXFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
fi