summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-10 04:38:21 +0300
committerDimitris Kiziridis2020-05-10 04:38:21 +0300
commit53f18c1c4981d978d11552a356c3f4e9b3b2f1f5 (patch)
treeae3b677e041414052c9ca61f9876731d08dc293f
parentf6b3a687d8426160ca4723cda70bdef426c2cf0e (diff)
downloadaur-53f18c1c4981d978d11552a356c3f4e9b3b2f1f5.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb1c3c3ef557..f01e595067a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,12 @@ pkgbase = chyle-bin
url = https://github.com/antham/chyle
arch = x86_64
license = MIT
+ depends = glibc
provides = chyle
- source = https://github.com/antham/chyle/releases/download/v1.9.0/chyle_linux_amd64
- md5sums = 3b07bd456a017f4e23d829594826c920
+ source = chyle-bin-1.9.0::https://github.com/antham/chyle/releases/download/v1.9.0/chyle_linux_amd64
+ source = LICENSE::https://raw.githubusercontent.com/antham/chyle/master/LICENSE.txt
+ sha256sums = 38f6ca88af59ddffeaa31f135f56277d7a916a7beaec2a8a819f1439d23de3d3
+ sha256sums = 74d52f9acb64851447fbb6618cdb58a693ca07c9bfec17076e415f752c81cffa
pkgname = chyle-bin
diff --git a/PKGBUILD b/PKGBUILD
index a0c32775f5a2..1fbc4f13472d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,13 @@ pkgdesc="Changelog generator: use a git repository and various data sources and
arch=('x86_64')
url='https://github.com/antham/chyle'
license=('MIT')
-source=("${url}/releases/download/v${pkgver}/chyle_linux_amd64")
-md5sums=('3b07bd456a017f4e23d829594826c920')
+depends=('glibc')
+source=("${pkgname}-${pkgver}::${url}/releases/download/v${pkgver}/chyle_linux_amd64"
+ 'LICENSE::https://raw.githubusercontent.com/antham/chyle/master/LICENSE.txt')
+sha256sums=('38f6ca88af59ddffeaa31f135f56277d7a916a7beaec2a8a819f1439d23de3d3'
+ '74d52f9acb64851447fbb6618cdb58a693ca07c9bfec17076e415f752c81cffa')
package() {
- install -Dm755 "${srcdir}"/chyle* "${pkgdir}/usr/bin/chyle"
+ install -Dm755 "${srcdir}"/${pkgname}-${pkgver} "${pkgdir}/usr/bin/chyle"
+ install -Dm644 "${srcdir}"/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file