summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-07-26 17:58:14 +0800
committerChocobo12017-07-26 17:58:14 +0800
commit540439064166938d587caa563befa19d819e91b4 (patch)
treef649097d656d2d3048e2758b0cdf494536558f8b
downloadaur-540439064166938d587caa563befa19d819e91b4.tar.gz
newpkg: butteraugli-git 1:290e395-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19093b59a439
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = butteraugli-git
+ pkgdesc = A tool for measuring perceived differences between images
+ pkgver = 290e395
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/google/butteraugli
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = glibc
+ depends = libjpeg
+ depends = libpng
+ provides = butteraugli
+ conflicts = butteraugli
+ source = git+https://github.com/google/butteraugli.git
+ sha256sums = SKIP
+
+pkgname = butteraugli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81573b15b497
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=butteraugli-git
+pkgver=290e395
+pkgrel=1
+epoch=1
+pkgdesc="A tool for measuring perceived differences between images"
+arch=('i686' 'x86_64')
+url="https://github.com/google/butteraugli"
+license=('Apache')
+depends=('glibc' 'libjpeg' 'libpng')
+makedepends=('git') #bazel
+provides=('butteraugli')
+conflicts=('butteraugli')
+source=("git+https://github.com/google/butteraugli.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "butteraugli"
+
+ git describe --always
+}
+
+build() {
+ cd "butteraugli/butteraugli"
+
+ make
+}
+
+package() {
+ cd "butteraugli"
+
+ install -d "$pkgdir/usr"
+ install -Dm755 "butteraugli/butteraugli" "$pkgdir/usr/bin/butteraugli"
+}