summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2015-06-14 01:41:12 +0900
committerorumin2015-06-14 01:41:12 +0900
commit5407db42e188c845115df90a0ebd6878d5cb4e0c (patch)
tree901ffa86a73e8d5599c135f7e0e57d1438cf2dca
downloadaur-5407db42e188c845115df90a0ebd6878d5cb4e0c.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eef071dd70f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sprout-git
+ pkgdesc = C++11/14 constexpr based Containers, Algorithms, Random numbers, Parsing, Ray tracing, Synthesizer, and others.
+ pkgver = 20141113
+ pkgrel = 2
+ url = http://github.com/bolero-MURAKAMI/Sprout
+ arch = i686
+ arch = x86_64
+ license = custom:boost
+ makedepends = git
+ depends = boost
+ optdepends = opencv
+ source = sprout-git::git+http://github.com/bolero-MURAKAMI/Sprout.git
+ md5sums = SKIP
+
+pkgname = sprout-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37188efcbcd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=sprout-git
+pkgdesc="C++11/14 constexpr based Containers, Algorithms, Random numbers, Parsing, Ray tracing, Synthesizer, and others."
+pkgver=20141113
+pkgver() {
+ cd "${pkgname}"
+ git describe --tags | sed 's/-/.g/'
+}
+pkgrel=2
+license=('custom:boost')
+arch=('i686' 'x86_64')
+url="http://github.com/bolero-MURAKAMI/Sprout"
+depends=('boost')
+makedepends=('git')
+optdepends=('opencv')
+source=('sprout-git::git+http://github.com/bolero-MURAKAMI/Sprout.git')
+md5sums=('SKIP')
+
+package() {
+ mkdir -p "${pkgdir}/usr/include/"
+ cp -r "${pkgname}/sprout" "${pkgdir}/usr/include/sprout"
+}