summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2017-09-07 19:55:51 +0300
committersurefire2017-09-07 19:55:51 +0300
commit540df92f91d46c841a16002e4cba99eed47fbc4a (patch)
treef8bc4e641cf9bea7520ae47430a1d9063991197f
parent80641f7a1a5ac30556772299ff487bc9f056e89d (diff)
downloadaur-540df92f91d46c841a16002e4cba99eed47fbc4a.tar.gz
upgpkg: nxt 1.11.8
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--logging.properties9
-rw-r--r--nxt.properties9
4 files changed, 26 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 946a002b7ed6..8a403f68512b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = nxt-git
pkgdesc = The Nxt Reference Software Client for use with the Nxt Cryptocurrency
- pkgver = 1.11.5+0+gfc25fd5a2
- pkgrel = 2
+ pkgver = 1.11.8+0+gd9f64fcec
+ pkgrel = 1
url = http://nxt.org
arch = any
license = MIT
license = GPL
license = MPL
license = APACHE
+ makedepends = git
makedepends = java-environment>=8
depends = java-runtime-headless>=8
depends = systemd
backup = etc/nxt/nxt.properties
backup = etc/nxt/logging.properties
- source = git+https://bitbucket.org/JeanLucPicard/nxt.git
+ source = git+https://bitbucket.org/Jelurida/nxt.git
source = logging.properties
source = nxt.properties
source = nxt.sysusers
@@ -22,8 +23,8 @@ pkgbase = nxt-git
source = nxt.desktop
source = nxt.sh
sha256sums = SKIP
- sha256sums = e00b9e5a605653faec8a4582ba004eff54c3692f60dc5a8c13c98119041195b1
- sha256sums = a65abe20dcec9ab4e7f39b5f16daee3e10a0b93dd78cadea47d45289ea145cbf
+ sha256sums = f1cf03e66d8b7510f6a6eb5558dcc924bdb193f4dacc1710d4e0e7d199d85603
+ sha256sums = 0445ee64f13c5a1a02d08550abef008640329d9aea8303d1d57317d0dfd87135
sha256sums = d73213fe300346c548e991af0797b23b3c608e803f741cd0ae89d3bb0549bfe3
sha256sums = 2f4775688213f0948364f1594162c12a6ec865501f7434847ce9bb7c73b11c59
sha256sums = 9c3ba3fff584e4baae3d9af88aa62418fd701094d2256e6e687300ce35b1f6f8
diff --git a/PKGBUILD b/PKGBUILD
index b8a093840f09..c14dcadd2741 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: David Parrish <daveparrish@gmail.com>
pkgname=nxt-git
-pkgver=1.11.5+0+gfc25fd5a2
-pkgrel=2
+pkgver=1.11.8+0+gd9f64fcec
+pkgrel=1
pkgdesc="The Nxt Reference Software Client for use with the Nxt Cryptocurrency"
arch=('any')
url="http://nxt.org"
license=('MIT' 'GPL' 'MPL' 'APACHE')
depends=('java-runtime-headless>=8' 'systemd')
-makedepends=('java-environment>=8')
-source=('git+https://bitbucket.org/JeanLucPicard/nxt.git'
+makedepends=('git' 'java-environment>=8')
+source=('git+https://bitbucket.org/Jelurida/nxt.git'
'logging.properties'
'nxt.properties'
'nxt.sysusers'
@@ -20,8 +20,8 @@ source=('git+https://bitbucket.org/JeanLucPicard/nxt.git'
backup=('etc/nxt/nxt.properties'
'etc/nxt/logging.properties')
sha256sums=('SKIP'
- 'e00b9e5a605653faec8a4582ba004eff54c3692f60dc5a8c13c98119041195b1'
- 'a65abe20dcec9ab4e7f39b5f16daee3e10a0b93dd78cadea47d45289ea145cbf'
+ 'f1cf03e66d8b7510f6a6eb5558dcc924bdb193f4dacc1710d4e0e7d199d85603'
+ '0445ee64f13c5a1a02d08550abef008640329d9aea8303d1d57317d0dfd87135'
'd73213fe300346c548e991af0797b23b3c608e803f741cd0ae89d3bb0549bfe3'
'2f4775688213f0948364f1594162c12a6ec865501f7434847ce9bb7c73b11c59'
'9c3ba3fff584e4baae3d9af88aa62418fd701094d2256e6e687300ce35b1f6f8'
@@ -65,5 +65,5 @@ package() {
install -Dm755 ../nxt.sh "$pkgdir/usr/bin/nxt"
# License files
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" ./{COPYING,3RD-PARTY-LICENSES,LICENSE}.txt
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" ./{3RD-PARTY-LICENSES,LICENSE}.txt
}
diff --git a/logging.properties b/logging.properties
index 089f4716474c..1fdca748ec56 100644
--- a/logging.properties
+++ b/logging.properties
@@ -1,8 +1,7 @@
java.util.logging.FileHandler.pattern = /var/log/nxt/nxt.log
-# Default logging level (OFF, FINE, INFO, WARNING, SEVERE)
-.level = SEVERE
+# Logging level (OFF, FINE, INFO, WARNING, SEVERE)
+java.util.logging.FileHandler.level = OFF
+java.util.logging.ConsoleHandler.level = INFO
-# Nxt logging level (OFF, FINE, INFO, WARNING, SEVERE)
-nxt.level = WARNING
-nxt.http.APIProxyServlet.level = INFO
+#Other settings look and copy from the file /usr/share/java/nxt/conf/logging-default.properties
diff --git a/nxt.properties b/nxt.properties
index 992a514805f4..1debbd743896 100644
--- a/nxt.properties
+++ b/nxt.properties
@@ -1,6 +1,15 @@
+# Set the socks proxy
+#socksProxyHost=127.0.0.1
+#socksProxyPort=9050
+#nxt.shareMyAddress=false
+
nxt.dbDir=/var/lib/nxt/nxt_db/nxt
nxt.testDbDir=/var/lib/nxt/nxt_test_db/nxt
+nxt.debugTraceLog=/var/log/nxt/nxt-trace.csv
+
nxt.apiResourceBase=/usr/share/nxt/html/www
nxt.javadocResourceBase=/usr/share/nxt/html/doc
nxt.uiResourceBase=/usr/share/nxt/html/nrs
+
+#Other settings look and copy from the file /usr/share/java/nxt/conf/nxt-default.properties