summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-02-23 01:17:36 +0000
committerDaniel Bermond2021-02-23 01:17:36 +0000
commit5427199be07a41b3614670dea3e2b683d683f306 (patch)
tree1e05cf3854f53bdf2076fb355e995ccaae8fd35b
parentdafd19a9ccd8aca540a365b80262fde1f00c47eb (diff)
downloadaur-5427199be07a41b3614670dea3e2b683d683f306.tar.gz
package(): install files according to upstream
executable zluda_with and library libzluda_redirect seems to be for windows only[1], although they also build for linux. Upstream GitHub actions[2] and distributed linux binaries[3] includes only libcuda on the package. Only the packaged windows binaries[4] includes zluda_with and library libzluda_redirect. References ---------- [1] https://github.com/vosen/ZLUDA/blob/v2/.github/workflows/rust.yml#L49-L55 [2] https://github.com/vosen/ZLUDA/blob/v2/.github/workflows/rust.yml#L29-L38 [3] https://github.com/vosen/ZLUDA/releases/download/v2/zluda-2-linux.zip [4] https://github.com/vosen/ZLUDA/releases/download/v2/zluda-2-windows.zip
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45fba286c85b..822dc203a1c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zluda-git
pkgdesc = A drop-in replacement for CUDA on Intel GPUs (git version)
pkgver = 2.r0.g4d3e37b
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vosen/ZLUDA/
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index f2795c82ef19..bd0a9de3063f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zluda-git
pkgver=2.r0.g4d3e37b
-pkgrel=1
+pkgrel=2
pkgdesc='A drop-in replacement for CUDA on Intel GPUs (git version)'
arch=('x86_64')
url='https://github.com/vosen/ZLUDA/'
@@ -39,10 +39,7 @@ check() {
}
package() {
- install -D -m755 ZLUDA/target/release/zluda_with -t "${pkgdir}/usr/bin"
- install -D -m644 ZLUDA/target/release/libnvcuda.so -t "${pkgdir}/usr/lib"
- install -D -m644 ZLUDA/target/release/libzluda_redirect.so -t "${pkgdir}/usr/lib"
+ install -D -m644 ZLUDA/target/release/libnvcuda.so "${pkgdir}/usr/lib/libcuda.so.1"
install -D -m644 ZLUDA/LICENSE-MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
- ln -s libnvcuda.so "${pkgdir}/usr/lib/libcuda.so"
- ln -s libnvcuda.so "${pkgdir}/usr/lib/libcuda.so.1"
+ ln -s libcuda.so.1 "${pkgdir}/usr/lib/libcuda.so"
}