summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-12-31 13:37:28 +0100
committerMartin T. H. Sandsmark2020-12-31 13:37:28 +0100
commit54362d32518aba6301c7775fdc5084b9259a3057 (patch)
tree46ff693d98233cb57fd3dd805fc1508de312824a
downloadaur-54362d32518aba6301c7775fdc5084b9259a3057.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b5aa3413189
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = turbo-button-git
+ pkgdesc = Simple tray app to toggle performance/power preference
+ pkgver = r2.c9f8cce
+ pkgrel = 1
+ url = https://github.com/sandsmark/turbo-button
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ provides = turbo-button
+ conflicts = turbo-button
+ source = git+https://github.com/sandsmark/turbo-button.git
+ md5sums = SKIP
+
+pkgname = turbo-button-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38636564eebb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+pkgname=turbo-button-git
+pkgver=r2.c9f8cce
+pkgrel=1
+pkgdesc="Simple tray app to toggle performance/power preference"
+arch=(i686 x86_64)
+url="https://github.com/sandsmark/turbo-button"
+license=(GPL3)
+depends=(qt5-base)
+makedepends=(git)
+provides=(turbo-button)
+conflicts=(turbo-button)
+source=('git+https://github.com/sandsmark/turbo-button.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd turbo-button
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../turbo-button \
+ -DCMAKE_BUILD_TYPE=Debug \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}