summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarlwgeorge2017-01-28 15:31:03 -0600
committercarlwgeorge2017-01-28 15:31:03 -0600
commit545105a52c5fa8bb994fb14354b54cc1d1a41871 (patch)
tree1dc4fadd04ee3349081d144cc2b759509510ab59
parentc5d3b5e1f863e2320b19f365bdb8f5a639bd97e8 (diff)
downloadaur-545105a52c5fa8bb994fb14354b54cc1d1a41871.tar.gz
3.3.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD41
3 files changed, 29 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3ad27be67df..74a016ed55f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Sat Jan 7 02:22:38 UTC 2017
+# Sat Jan 28 21:26:19 UTC 2017
pkgbase = python-swiftclient
pkgdesc = OpenStack Object Storage API Client Library
- pkgver = 3.2.0
- pkgrel = 2
+ pkgver = 3.3.0
+ pkgrel = 1
url = https://github.com/openstack/python-swiftclient
arch = any
license = Apache
makedepends = python-pbr
makedepends = python2-pbr
- source = https://tarballs.openstack.org/python-swiftclient/python-swiftclient-3.2.0.tar.gz
- sha256sums = 8761697584ab060520d6094e8394242ee3b94c643ed1f3fe1dbc67df585ab3fa
+ source = https://tarballs.openstack.org/python-swiftclient/python-swiftclient-3.3.0.tar.gz
+ sha256sums = 8b4d38d73ceb2ef4984b39fb924bf9b265050ca2beb5c6bf29cb9f34ccd0bf7d
pkgname = python-swiftclient
depends = python-requests>=1.1
@@ -18,6 +18,6 @@ pkgname = python-swiftclient
pkgname = python2-swiftclient
depends = python2-futures>=3.0
- depends = python-requests>=1.1
- depends = python-six>=1.5.2
+ depends = python2-requests>=1.1
+ depends = python2-six>=1.5.2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..859dff1cf895
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# sources
+*.tar.gz
+
+# build logs
+*.log
+
+# packages
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 5e5ab59ed0ad..08407acbf76a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,47 +4,34 @@ _name="python-swiftclient"
_module="${_name#python-}"
_cmd="${_module%client}"
-pkgname=("python-${_module}" "python2-${_module}")
-pkgver="3.2.0"
-pkgrel="2"
+pkgname=("python-$_module" "python2-$_module")
+pkgver=3.3.0
+pkgrel=1
pkgdesc="OpenStack Object Storage API Client Library"
arch=("any")
-url="https://github.com/openstack/${_name}"
+url="https://github.com/openstack/$_name"
license=("Apache")
makedepends=("python-pbr" "python2-pbr")
-source=("https://tarballs.openstack.org/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('8761697584ab060520d6094e8394242ee3b94c643ed1f3fe1dbc67df585ab3fa')
-
-prepare() {
- cp -a "${srcdir}/${_name}-${pkgver}" "${srcdir}/${_name}-${pkgver}-python2"
- # futures is only needed for python 2
- sed -ri '/futures/d' "${_name}-${pkgver}/requirements.txt"
-}
-
-build() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py build
- cd "${srcdir}/${_name}-${pkgver}-python2"
- python2 setup.py build
-}
+source=("https://tarballs.openstack.org/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('8b4d38d73ceb2ef4984b39fb924bf9b265050ca2beb5c6bf29cb9f34ccd0bf7d')
package_python-swiftclient() {
depends=(
"python-requests>=1.1"
"python-six>=1.5.2"
)
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
}
package_python2-swiftclient() {
depends=(
"python2-futures>=3.0"
- "python-requests>=1.1"
- "python-six>=1.5.2"
+ "python2-requests>=1.1"
+ "python2-six>=1.5.2"
)
- cd "${srcdir}/${_name}-${pkgver}-python2"
- python2 setup.py install --skip-build --root="${pkgdir}" --optimize=1
- mv "${pkgdir}/usr/bin/${_cmd}" "${pkgdir}/usr/bin/${_cmd}2"
- mv "${pkgdir}/usr/share/man/man1/${_cmd}.1" "${pkgdir}/usr/share/man/man1/${_cmd}2.1"
+ cd "$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ mv "$pkgdir/usr/bin/$_cmd" "$pkgdir/usr/bin/${_cmd}2"
+ mv "$pkgdir/usr/share/man/man1/$_cmd.1" "$pkgdir/usr/share/man/man1/${_cmd}2.1"
}