summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2020-06-30 21:47:32 +0200
committerfordprefect2020-06-30 21:47:32 +0200
commit545a08beb091818ea7b3e7d611b3492d570a98f9 (patch)
tree14e428ebbf026363379472bdc445339608ddd7a6
parent698560c7bff9f51ab1d80474395f428bfe8c7453 (diff)
downloadaur-545a08beb091818ea7b3e7d611b3492d570a98f9.tar.gz
0.5, streamlining
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--use_cc.patch12
3 files changed, 11 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09a9f6b1a997..695b00a5d5f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Sep 6 15:43:13 UTC 2018
pkgbase = luaunbound
pkgdesc = drop-in replacement for Prosodys internal DNS library with a binding to libunbound
- pkgver = 0.2_1
+ pkgver = 0.5
pkgrel = 1
epoch = 1
url = https://www.zash.se/luaunbound.html
@@ -17,10 +15,8 @@ pkgbase = luaunbound
makedepends = ccache
depends = unbound
optdepends = luajit: jit for lua
- source = luaunbound-0.2_1.tar.gz::https://github.com/LuaDist2/luaunbound/archive/0.2-1.tar.gz
- source = use_cc.patch
- sha512sums = SKIP
- sha512sums = 6b11dfe9f5de743f101463fb3fb2144fe3aff75e7e19036f67d0e0b8adc8c36db73cf73d0aba483d651f8f5b2773093adc27e788354b165314c777e8de45bf28
+ source = https://code.zash.se/dl/luaunbound/luaunbound-0.5.tar.gz
+ sha512sums = 8bd76a5e17d21b704953f5e2963b9ac0b4d3c6b32fd3dec8313ccea708a7606c6f6cdf088be6395e51bcaf4b2ca589e402dfb8bafdca53b6eda6088c0d6592b5
pkgname = luaunbound
diff --git a/PKGBUILD b/PKGBUILD
index 8af45ab56dbe..9169c144798b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: fordprefect <fordprefect@dukun.de>
# Contributor: jhass <me@jhass.eu>
pkgname=luaunbound
-pkgver=0.2_1
-_pkgver=0.2-1
+pkgver=0.5
epoch=1
pkgrel=1
pkgdesc="drop-in replacement for Prosodys internal DNS library with a binding to libunbound"
@@ -13,23 +12,22 @@ depends=("unbound")
makedepends=("mercurial" "unbound" "lua" "libxslt" "ccache")
optdepends=("luajit: jit for lua")
install=luaunbound.install
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/LuaDist2/luaunbound/archive/${_pkgver}.tar.gz" "use_cc.patch")
-sha512sums=('SKIP'
- '6b11dfe9f5de743f101463fb3fb2144fe3aff75e7e19036f67d0e0b8adc8c36db73cf73d0aba483d651f8f5b2773093adc27e788354b165314c777e8de45bf28')
+source=("https://code.zash.se/dl/luaunbound/luaunbound-${pkgver}.tar.gz")
+sha512sums=('8bd76a5e17d21b704953f5e2963b9ac0b4d3c6b32fd3dec8313ccea708a7606c6f6cdf088be6395e51bcaf4b2ca589e402dfb8bafdca53b6eda6088c0d6592b5')
prepare() {
- cd "$srcdir/$pkgname-$_pkgver"
- patch -p1 < "$srcdir/use_cc.patch"
+ cd "$srcdir/$pkgname-$pkgver"
+ # use CC
+ sed -i 's/(LD)/(CC)/g' GNUmakefile
}
build() {
- cd "$srcdir/$pkgname-$_pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
make all
}
package() {
- cd "$srcdir/$pkgname-$_pkgver"
- install -Dm644 use_unbound.lua "$pkgdir/etc/prosody/use_unbound.lua"
+ cd "$srcdir/$pkgname-$pkgver"
install -Dm755 lunbound.so "$pkgdir/usr/lib/prosody/util/lunbound.so"
install -Dm644 README.markdown "$pkgdir/usr/share/doc/luaunbound/README"
install -Dm444 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
diff --git a/use_cc.patch b/use_cc.patch
deleted file mode 100644
index 85ffab9b3e42..000000000000
--- a/use_cc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r f270a1cf86ce Makefile
---- a/Makefile Sun Jan 10 19:49:52 2016 +0100
-+++ b/Makefile Mon Jun 20 15:34:28 2016 +0200
-@@ -33,7 +33,7 @@
- xsltproc root-anchors.xsl root-anchors.xml > $@
-
- %.so: %.o
-- $(LD) $(LDFLAGS) -o $@ $^ $(LDLIBS)
-+ $(CC) $(LDFLAGS) -o $@ $^ $(LDLIBS)
-
- install:
- install -d $(DESTDIR)$(LUA_LIBDIR)/