summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralvin jian2015-11-26 23:54:40 +0800
committeralvin jian2015-11-26 23:54:40 +0800
commit54826cc3affea04c6fb03dcc76cde12be4b1a08f (patch)
treeb01f1ad228d217944de6a7cd0dbdeabecf93a161
downloadaur-54826cc3affea04c6fb03dcc76cde12be4b1a08f.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdd03f95f3a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-autobgch
+ pkgdesc = A simple and automatic wallpaper changer supporting various backends for Linux
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/AlvinJian/auto_background_changer
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ optdepends = feh: lightweight window manager support
+ source = python-autobgch-0.3.tar.gz::https://github.com/AlvinJian/auto_background_changer/archive/v0.3.tar.gz
+ md5sums = df6a8a60553c09842f41c59cfdd457a9
+
+pkgname = python-autobgch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b743b988db06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/Python_Package_Guidelines for more
+# information on Python packaging.
+
+# Maintainer: Alvin Jian <alvinchien0624@gmail.com>
+pkgname=python-autobgch
+pkgver=0.3
+pkgrel=1
+pkgdesc="A simple and automatic wallpaper changer supporting various backends for Linux"
+arch=('any')
+url="https://github.com/AlvinJian/auto_background_changer"
+license=('MIT')
+depends=('python')
+optdepends=('feh: lightweight window manager support')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AlvinJian/auto_background_changer/archive/v${pkgver}.tar.gz")
+md5sums=('df6a8a60553c09842f41c59cfdd457a9')
+
+package() {
+ cd "$srcdir/auto_background_changer-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}