summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2022-01-13 21:29:36 +0100
committerNarrat2022-01-13 21:29:36 +0100
commit5490f4c4ec19ed49789838dec3b21250e5d1e07f (patch)
tree1fab09f60aa0203ad258e6f495b64df31763a5fe
parentf374002be0339b4e933e36786d20b8d20f761e5d (diff)
downloadaur-5490f4c4ec19ed49789838dec3b21250e5d1e07f.tar.gz
Tibia: drop openssl 1.0.x patch
It seems upstream does use openssl 1.1 since some time.
-rw-r--r--.SRCINFO5
-rw-r--r--01_openssl102.patch8
-rw-r--r--PKGBUILD6
3 files changed, 2 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a12303b4c72..75c553408c78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,18 +11,15 @@ pkgbase = tibia
depends = libgl
depends = libice
depends = libxext
- depends = openssl-1.0
+ depends = openssl
depends = pcre
depends = qt5-base
depends = qt5-declarative
source = tibia.tar.gz::https://static.tibia.com/download/tibia.x64.tar.gz
source = tibia-agreement.php::https://www.tibia.com/support/agreement.php
- source = 01_openssl102.patch
source = 02_freetype.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = f3a7c01c0664155a82f00a3d84d6d4a01f7786e872f3a12ae89886542bc43482
sha256sums = 55d87bd8f32728cd47757a195102e2af2d10a1501d9370af86606b2c75211515
pkgname = tibia
-
diff --git a/01_openssl102.patch b/01_openssl102.patch
deleted file mode 100644
index 13a9b714a51a..000000000000
--- a/01_openssl102.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- start-tibia-launcher.sh
-+++ start-tibia-launcher.sh
-@@ -5,4 +5,4 @@
- SCRIPT=$(readlink -f "$0")
- PATH=$(dirname "$SCRIPT")
-
--exec "$PATH/Tibia"
-+LD_LIBRARY_PATH="$PATH:/usr/lib/openssl-1.0/" exec "$PATH/Tibia"
diff --git a/PKGBUILD b/PKGBUILD
index 6d6217348f69..634e29cac9d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="fast-paced free massively multiplayer online role-playing game"
arch=('x86_64')
url="http://www.tibia.com"
license=('custom')
-depends=('glu' 'libgl' 'libice' 'libxext' 'openssl-1.0' 'pcre' 'qt5-base' 'qt5-declarative')
+depends=('glu' 'libgl' 'libice' 'libxext' 'openssl' 'pcre' 'qt5-base' 'qt5-declarative')
makedepends=('gendesk' 'python-html2text')
DLAGENTS=("https::/usr/bin/curl --compressed -fLC - --retry 0 --retry-delay 0 -e %u -o %o %u"
@@ -15,12 +15,10 @@ DLAGENTS=("https::/usr/bin/curl --compressed -fLC - --retry 0 --retry-delay 0 -e
source=("${pkgname}.tar.gz::https://static.tibia.com/download/tibia.x64.tar.gz"
"${pkgname}-agreement.php::https://www.tibia.com/support/agreement.php"
- "01_openssl102.patch"
"02_freetype.patch")
sha256sums=('SKIP'
'SKIP'
- 'f3a7c01c0664155a82f00a3d84d6d4a01f7786e872f3a12ae89886542bc43482'
'55d87bd8f32728cd47757a195102e2af2d10a1501d9370af86606b2c75211515')
prepare() {
@@ -28,8 +26,6 @@ prepare() {
html2text "${pkgname}-agreement.php" > LICENSE
cd Tibia
- # Tibia relies on openssl 1.0.x
- patch -Np0 -i "${srcdir}/01_openssl102.patch"
# Tibia relies on specific freetype version
patch -Np0 -i "${srcdir}/02_freetype.patch"
}