summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-06-16 17:36:23 +0200
committerhaawda2019-06-16 17:36:23 +0200
commit5499573e5d4f7ac46f11daddf888877cbef0ae3a (patch)
treefba9191468e5b23590adecede612d1534a7a74b2
parent2d04fa0217f3eb4dd045ccf49b00c9cb1255f60a (diff)
downloadaur-5499573e5d4f7ac46f11daddf888877cbef0ae3a.tar.gz
major rewrite
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d5ffc0fe39f..28daf15ceead 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ccl-git
pkgdesc = The Clozure Common Lisp implementation
- pkgver = 1.12.dev.3.44.g8fa7fdfc
+ pkgver = 1.12.dev.5.3.gb5233ade
pkgrel = 1
epoch = 1
url = http://ccl.clozure.com/
@@ -15,10 +15,11 @@ pkgbase = ccl-git
provides = ccl
conflicts = ccl-bin
conflicts = ccl
+ noextract = linuxx86.tar.gz
source = git+https://github.com/Clozure/ccl.git
- source = http://svn.clozure.com/publicsvn/openmcl/trunk/source/scripts/get-binaries
- sha1sums = SKIP
- sha1sums = 3160281c3c8ed63b0019fa00139026d9fdb3259e
+ source = https://github.com/Clozure/ccl/releases/download/v1.12-dev.5/linuxx86.tar.gz
+ sha256sums = SKIP
+ sha256sums = abf692f4a05a6667306f2b885128ff4c493b6ab4c0c470e92f9d93ddfbf211df
pkgname = ccl-git
diff --git a/PKGBUILD b/PKGBUILD
index 47a1fc572dff..dd78b55fe094 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ccl-git
epoch=1
-pkgver=1.12.dev.3.44.g8fa7fdfc
+pkgver=1.12.dev.5.3.gb5233ade
pkgrel=1
pkgdesc="The Clozure Common Lisp implementation"
url="http://ccl.clozure.com/"
@@ -15,21 +15,19 @@ makedepends=('git' 'subversion')
provides=('common-lisp' 'cl-asdf' 'ccl')
conflicts=('ccl-bin' 'ccl')
_arch=64
-source=("git+https://github.com/Clozure/ccl.git" http://svn.clozure.com/publicsvn/openmcl/trunk/source/scripts/get-binaries)
-sha1sums=('SKIP'
- '3160281c3c8ed63b0019fa00139026d9fdb3259e')
+source=("git+https://github.com/Clozure/ccl.git" https://github.com/Clozure/ccl/releases/download/v1.12-dev.5/linuxx86.tar.gz)
+sha256sums=('SKIP'
+ 'abf692f4a05a6667306f2b885128ff4c493b6ab4c0c470e92f9d93ddfbf211df')
+noextract=('linuxx86.tar.gz')
pkgver() {
cd ccl
git describe --tags|tr - .|cut -c2-
- #printf %s.%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
}
prepare() {
- sed -i "s+svn export+svn export --force+" get-binaries
cd ccl
- chmod 700 ../get-binaries
- ../get-binaries linuxx86
+ bsdtar xf "$srcdir"/linuxx86.tar.gz
}
build() {