summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2016-03-22 12:53:08 -0400
committerEric Berquist2016-03-22 12:53:08 -0400
commit549fe75ebf542197403b502fd6e5e74bdc573865 (patch)
tree8202e9da5516a9bd6771f69ae1a841d61f1148a6
downloadaur-549fe75ebf542197403b502fd6e5e74bdc573865.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD39
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4c3770a05ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Tue Mar 22 16:45:35 UTC 2016
+pkgbase = nwchem-bin
+ pkgdesc = Open Source High-Performance Computational Chemistry (Debian binary build)
+ pkgver = 6.6.r27746.2
+ pkgrel = 1
+ url = http://www.nwchem-sw.org
+ arch = i686
+ arch = x86_64
+ license = custom:ECL2.0
+ license = GPL3
+ depends = lapack
+ depends = python2
+ depends = openmpi
+ depends = nwchem-data
+ provides = nwchem
+ conflicts = nwchem
+ options = !strip
+ options = libtool
+ options = staticlibs
+ source = http://ftp.us.debian.org/debian/pool/main/n/nwchem/nwchem_6.6+r27746-2_.deb
+
+pkgname = nwchem-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b32e95368c05
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg files
+pkg/
+src/
+*.xz
+
+# source files
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20b084c95624
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
+
+_pkgname=nwchem
+pkgname=${_pkgname}-bin
+pkgver=6.6.r27746.2
+_pkgver=6.6+r27746-2
+pkgrel=1
+pkgdesc="Open Source High-Performance Computational Chemistry (Debian binary build)"
+arch=("i686" "x86_64")
+url="http://www.nwchem-sw.org"
+license=("custom:ECL2.0" "GPL3")
+depends=("lapack" "python2" "openmpi" "nwchem-data")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+options=("!strip" "libtool" "staticlibs")
+case "${CARCH}" in
+ "i686")
+ _arch='i386'
+ _sha256sum='1b19f6e6ac88b093698bff41aed898fee8ff4f31af908d4c396a70b95504336d'
+ ;;
+ "x86_64")
+ _arch='amd64'
+ _sha256sum='aa5b19b249a261797dca8a8b8c8b4c99fa991b79a330df5399252379197ca745'
+ ;;
+esac
+source=("http://ftp.us.debian.org/debian/pool/main/n/nwchem/nwchem_${_pkgver}_${_arch}.deb")
+sha256sums=("${_sha256sum}")
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "${pkgdir}/"
+
+ msg2 "Adding license..."
+ install -Dm644 "${pkgdir}"/usr/share/doc/"${_pkgname}"/copyright "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+
+ msg2 "Removing Debian extras..."
+ rm -r "${pkgdir}"/usr/share/lintian
+ rm -r "${pkgdir}"/usr/share/doc-base
+}