summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-05-12 01:45:08 +0200
committerChristopher Arndt2023-05-12 01:45:08 +0200
commit54aca8f75653ce92bbe67ab911b12f4d1c048b45 (patch)
tree8c385d7037063c370f7620eb74785993b5eaf843
parentbdc2292ef28bfb08fcde4a1f90158ce6db8755ab (diff)
downloadaur-54aca8f75653ce92bbe67ab911b12f4d1c048b45.tar.gz
Update to upstream version 3.0.1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c110f94c80d..5cb4caceb816 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = restview
- pkgdesc = A viewer for ReStructuredText documents that renders them on the fly.
- pkgver = 3.0.0
+ pkgdesc = A viewer for ReStructuredText documents that renders them on the fly
+ pkgver = 3.0.1
pkgrel = 1
- url = http://mg.pov.lt/restview/
+ url = https://mg.pov.lt/restview/
arch = any
license = GPL
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-docutils
depends = python-pygments
depends = python-readme-renderer
- depends = python-setuptools
- options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/r/restview/restview-3.0.0.tar.gz
- sha256sums = 2b989610aaed2fd42da64f6cdc539cf3ee70ce370bcba872db72421ad515dd1e
+ source = https://files.pythonhosted.org/packages/source/r/restview/restview-3.0.1.tar.gz
+ sha256sums = 8c1a171c159d46d15d5569f77021828883a121d6f9baf758d641fc1e54b05ae5
pkgname = restview
diff --git a/.gitignore b/.gitignore
index d52f2160bf03..b95d20ba8c6d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
src/
pkg/
restview-*.tar.gz
-restview-*.pkg.tar.xz
-restview-*.pkg.tar.zst
+restview-*.pkg.tar.*
restview-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 4159bea47ed7..e63a8c6d417f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,24 @@
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
pkgname=restview
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
-pkgdesc="A viewer for ReStructuredText documents that renders them on the fly."
+pkgdesc='A viewer for ReStructuredText documents that renders them on the fly'
arch=(any)
-url="http://mg.pov.lt/restview/"
-license=('GPL')
-depends=('python-docutils' 'python-pygments' 'python-readme-renderer' 'python-setuptools')
-options=(!emptydirs)
-source=(
- "https://files.pythonhosted.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
-)
-sha256sums=('2b989610aaed2fd42da64f6cdc539cf3ee70ce370bcba872db72421ad515dd1e')
+url='https://mg.pov.lt/restview/'
+license=(GPL)
+depends=(python-docutils python-pygments python-readme-renderer)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('8c1a171c159d46d15d5569f77021828883a121d6f9baf758d641fc1e54b05ae5')
build() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- python setup.py build
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- python setup.py install --skip-build --root="${pkgdir}"/ --optimize=1
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
}