summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2022-09-21 21:29:43 +0300
committerViktor Drobot2022-09-21 21:29:43 +0300
commit54c2de7a176d2b94a1491ab11c1084c3fa26d738 (patch)
tree0044c2b5de8d0fb3621e9080d63b26cfa9af4536
parent4de15826a5e7cf6c40a1dbd5cecbcf04a4f0d325 (diff)
downloadaur-54c2de7a176d2b94a1491ab11c1084c3fa26d738.tar.gz
Fix hamlib build issue
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fix_hamlib.patch41
3 files changed, 50 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 295f5320e750..07b546812184 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dream
pkgdesc = A software radio for AM and Digital Radio Mondiale (DRM)
pkgver = 2.1.1
- pkgrel = 3
+ pkgrel = 4
url = https://sourceforge.net/projects/drm
arch = i686
arch = x86_64
@@ -22,7 +22,9 @@ pkgbase = dream
depends = qt5-base
source = https://sourceforge.net/projects/drm/files/dream/2.1.1/dream-2.1.1-svn808.tar.gz
source = fix_qwttext.patch
+ source = fix_hamlib.patch
sha256sums = 417734a197ed596a08e75363c304be9b4595f2f21581bc64fec47c49f733bb05
sha256sums = a5c521644f9a95f73adc4eefa8bb690642caefa59b028ddd9b34aea231af96f2
+ sha256sums = df8dbc1f5c2e6e181377bf7832dbf057018dd1be2b9cdfa8d9a24db3f0f9b76a
pkgname = dream
diff --git a/PKGBUILD b/PKGBUILD
index 0191a9b9e1eb..542ae2f1279a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dream
pkgver=2.1.1
-pkgrel=3
+pkgrel=4
pkgdesc="A software radio for AM and Digital Radio Mondiale (DRM)"
arch=(i686 x86_64)
url="https://sourceforge.net/projects/drm"
@@ -10,14 +10,17 @@ license=(GPL2)
depends=(faad2 libpcap libpulse fftw opus libsndfile speexdsp hamlib libpulse qwt qt5-webkit qt5-svg qt5-base)
makedepends=(patch)
source=("https://sourceforge.net/projects/drm/files/dream/${pkgver}/${pkgname}-${pkgver}-svn808.tar.gz"
- "fix_qwttext.patch")
+ "fix_qwttext.patch"
+ "fix_hamlib.patch")
sha256sums=('417734a197ed596a08e75363c304be9b4595f2f21581bc64fec47c49f733bb05'
- 'a5c521644f9a95f73adc4eefa8bb690642caefa59b028ddd9b34aea231af96f2')
+ 'a5c521644f9a95f73adc4eefa8bb690642caefa59b028ddd9b34aea231af96f2'
+ 'df8dbc1f5c2e6e181377bf7832dbf057018dd1be2b9cdfa8d9a24db3f0f9b76a')
build() {
cd "${srcdir}/${pkgname}"
patch -Np0 -i "${srcdir}/fix_qwttext.patch"
+ patch -Np0 -i "${srcdir}/fix_hamlib.patch"
qmake-qt5 dream.pro
make
diff --git a/fix_hamlib.patch b/fix_hamlib.patch
new file mode 100644
index 000000000000..a96529eaad2a
--- /dev/null
+++ b/fix_hamlib.patch
@@ -0,0 +1,41 @@
+--- src/util/Hamlib.cpp 2013-11-11 20:33:41.000000000 +0400
++++ src/util/Hamlib.cpp 2022-07-08 11:35:55.051764364 +0300
+@@ -421,21 +421,21 @@
+
+ /* Hamlib Model ID */
+ SetHamlibModelID(model);
+ }
+
+- s.Put("Hamlib", "hamlib-model", model);
++ s.Put("Hamlib", "hamlib-model", (int)model);
+ s.Put("Hamlib", "hamlib-config", strHamlibConf);
+ s.Put("Hamlib", "settings", strSettings);
+ s.Put("Hamlib", "freqoffset", iFreqOffset);
+ }
+
+ void
+ CHamlib::SaveSettings(CSettings & s)
+ {
+ /* Hamlib Model ID */
+- s.Put("Hamlib", "hamlib-model", iHamlibModelID);
++ s.Put("Hamlib", "hamlib-model", (int)iHamlibModelID);
+
+ /* Hamlib configuration string */
+ stringstream ss;
+ string sep = "";
+ for (map < string, string >::iterator i = config.begin();
+--- src/GUI-QT/DialogUtil.h 2013-11-11 20:33:43.000000000 +0400
++++ src/GUI-QT/DialogUtil.cpp 2022-07-08 11:39:51.420130677 +0300
+@@ -46,11 +46,11 @@
+ #include <QAction>
+
+ #include <qwt_thermo.h> /* S-Meter */
+
+ class CRig;
+-typedef int rig_model_t;
++typedef uint32_t rig_model_t;
+
+ /* Definitions ****************************************************************/
+
+ /* Definition for Courier font */
+ #ifdef _WIN32