summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Sarawinski2019-10-18 23:36:35 +0200
committerTimo Sarawinski2019-10-18 23:36:35 +0200
commit54dba1a5abd06e37af9b0bf218af1e6266f6809d (patch)
treeff6e3f16be0df0853704a9cb5250721eb1c3bc91
parent631570bc276ec79815adc330eaa030dd09ae6c0e (diff)
downloadaur-54dba1a5abd06e37af9b0bf218af1e6266f6809d.tar.gz
update
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
-rw-r--r--tp.patch22
3 files changed, 1 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39ab11bdc706..1987948e4279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,6 @@ pkgbase = thinkpad_wmi-dkms-git
provides = thinkpad_wmi-dkms-git
conflicts = thinkpad_wmi-dkms-git
source = git+https://github.com/iksaif/thinkpad-wmi.git
- source = tp.patch
md5sums = SKIP
md5sums = 38fc92d73e10b31f146dd4056c261b2d
diff --git a/PKGBUILD b/PKGBUILD
index a87797361c5c..c27bdd5ddfe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ makedepends=('git')
depends=('dkms')
provides=("${pkgname}")
conflicts=("${pkgname}")
-source=("git+https://github.com/iksaif/thinkpad-wmi.git" tp.patch)
+source=("git+https://github.com/iksaif/thinkpad-wmi.git")
md5sums=('SKIP'
'38fc92d73e10b31f146dd4056c261b2d')
@@ -21,11 +21,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${basename}"/drivers/platform/x86
- patch -Np0 -i "${srcdir}/"tp.patch
-}
-
package() {
dkmsdir="${pkgdir}/usr/src/${basename}-${pkgver}"
install -d "${dkmsdir}"
diff --git a/tp.patch b/tp.patch
deleted file mode 100644
index b09d3eed3975..000000000000
--- a/tp.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- thinkpad-wmi.c
-+++ thinkpad-wmi.c
-@@ -31,6 +31,7 @@
- #include <linux/device.h>
- #include <linux/init.h>
- #include <linux/kernel.h>
-+#include <linux/version.h>
- #include <linux/module.h>
- #include <linux/platform_device.h>
- #include <linux/seq_file.h>
-@@ -1297,7 +1298,11 @@
- return 0;
- }
-
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(5, 3, 0))
-+static int thinkpad_wmi_probe(struct wmi_device *wdev, const void *context)
-+#else
- static int thinkpad_wmi_probe(struct wmi_device *wdev)
-+#endif
- {
- return thinkpad_wmi_add(wdev);
- }