summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2015-06-16 16:39:22 +0200
committerChristoph Haag2015-06-16 16:39:22 +0200
commit5503702191818828f9e905521d8e88d64bd4bc06 (patch)
tree402883effd48def37ec730528b8ae7de04ad7f37
downloadaur-5503702191818828f9e905521d8e88d64bd4bc06.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edbfea078524
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libepoxy-git
+ pkgdesc = Epoxy is a library for handling OpenGL function pointer management for you
+ pkgver = 1.2.25.r229.ga2a5190
+ pkgrel = 1
+ url = https://github.com/anholt/libepoxy
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = xorg-util-macros
+ makedepends = libx11
+ makedepends = python
+ makedepends = git
+ provides = libepoxy
+ conflicts = libepoxy
+ options = !libtool
+ source = git+https://github.com/anholt/libepoxy.git
+ md5sums = SKIP
+
+pkgname = libepoxy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43aab84d1b00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=libepoxy-git
+_name=libepoxy
+pkgver=1.2.25.r229.ga2a5190
+pkgrel=1
+pkgdesc="Epoxy is a library for handling OpenGL function pointer management for you"
+url="https://github.com/anholt/libepoxy"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=() # ???
+makedepends=("xorg-util-macros" "libx11" "python" "git")
+provides=("libepoxy")
+conflicts=("libepoxy")
+options=('!libtool')
+source=("git+https://github.com/anholt/libepoxy.git")
+
+pkgver() {
+ cd $_name
+ #echo $(git rev-list --count HEAD).$(git describe --tags --long | tr -d v | tr - .)
+ echo $(git describe --long --tags | cut -d 'g' -f1)r$(git rev-list HEAD --count).g$(git describe --always) | tr -d v | tr - .
+}
+
+build() {
+ # export CFLAGS="-Og -ggdb"
+ # export CXXFLAGS="-Og -ggdb"
+ cd "$_name"
+
+ ./autogen.sh --prefix=/usr
+ #./configure --prefix=/usr
+}
+
+#check() {
+# cd "$_name"
+# make -k check
+#}
+
+package() {
+ cd "$_name"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('SKIP')