summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2019-12-10 21:46:53 -0800
committerMike Swanson2019-12-10 21:46:53 -0800
commit550d6a2ddaedc2be70bbe57cbb69f55f74ae3d34 (patch)
tree782b7076d8e8d30ea2d245394679e21248f7f8e4
parent22ad81d1e5198e2f4d4e24657ee8a2707e9971c9 (diff)
downloadaur-550d6a2ddaedc2be70bbe57cbb69f55f74ae3d34.tar.gz
Update to 1.49
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Makefile-cflags-and-destdir.patch40
-rw-r--r--PKGBUILD20
3 files changed, 62 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ffcefb27e6b..a40cf7f974ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cvs-fast-export
pkgdesc = Export RCS or CVS history as a fastimport stream.
- pkgver = 1.48
+ pkgver = 1.49
pkgrel = 1
url = http://www.catb.org/esr/cvs-fast-export/
arch = i686
@@ -8,8 +8,10 @@ pkgbase = cvs-fast-export
license = GPL2
makedepends = asciidoc
depends = python
- source = https://gitlab.com/esr/cvs-fast-export/-/archive/1.48/cvs-fast-export-1.48.tar.gz
- sha512sums = e260e281b3b0650ffff3882629cc96d964fc855b1fc72f9c8849e3e342acd91f2be07c0243915eac6286a936812cc1005e86079aaaeac2a150eba3c4b995b260
+ source = https://gitlab.com/esr/cvs-fast-export/-/archive/1.49/cvs-fast-export-1.49.tar.gz
+ source = 0001-Makefile-cflags-and-destdir.patch
+ sha512sums = 4e729c564800ed364b6d1bae8ffc2144e508e1a24677f5ab082843ce9d4263ea2ec80facbe0d1fdf59aabae6c4bf7cba30350517458400c98545a6853ad49f31
+ sha512sums = 49c0a9fbe187a07dce9c5c7636aa7e48eaeff56fff9afb5f4e4e9930873a3bddccad112d0c05e8827a3c9bc1ece4867ace5682979762a0469c0774c2b195f93b
pkgname = cvs-fast-export
diff --git a/0001-Makefile-cflags-and-destdir.patch b/0001-Makefile-cflags-and-destdir.patch
new file mode 100644
index 000000000000..f356c6d22771
--- /dev/null
+++ b/0001-Makefile-cflags-and-destdir.patch
@@ -0,0 +1,40 @@
+diff --git a/Makefile b/Makefile
+index 2cca402..86f4c4e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -25,7 +25,7 @@ target=$(DESTDIR)$(prefix)
+ parsedir:=$(.PARSEDIR)
+ srcdir=$(dir $(abspath $(firstword $(MAKEFILE_LIST))))$(parsedir)
+ VPATH=$(srcdir)
+-mandir?=$(prefix)/share/man
++mandir?=$(DESTDIR)$(prefix)/share/man
+
+ INSTALL = install
+ TAR = tar
+@@ -34,7 +34,7 @@ GCC_WARNINGS1=-Wall -Wpointer-arith -Wstrict-prototypes
+ GCC_WARNINGS2=-Wmissing-prototypes -Wmissing-declarations
+ GCC_WARNINGS3=-Wno-unused-function -Wno-unused-label -Wno-format-zero-length
+ GCC_WARNINGS=$(GCC_WARNINGS1) $(GCC_WARNINGS2) $(GCC_WARNINGS3)
+-CFLAGS=$(GCC_WARNINGS)
++CFLAGS+=$(GCC_WARNINGS)
+ CPPFLAGS += -I. -I$(srcdir)
+ #LIBS=-lrt
+ CPPFLAGS += -DVERSION=\"$(VERSION)\"
+@@ -44,7 +44,7 @@ CFLAGS += -pthread
+ CPPFLAGS += -DTHREADS
+
+ # Optimizing for speed. Comment this out for distribution builds
+-CFLAGS += -march=native
++# CFLAGS += -march=native
+
+ # To enable debugging of the Yacc grammar, uncomment the following line
+ #CPPFLAGS += -DYYDEBUG=1
+@@ -78,7 +78,7 @@ CPPFLAGS+=-Drestrict=__restrict__
+ # CFLAGS += -pg
+ # Warning: Using -O3 has been seen to cause core dumps on repositories with
+ # very long revision names - some bounds check gets optimized away. Don't do that.
+-CFLAGS += -O2
++# CFLAGS += -O2
+ # If your toolchain supports link time optimization this is a cheap speedup
+ # CFLAGS += -flto
+ # CFLAGS += -g
diff --git a/PKGBUILD b/PKGBUILD
index de0755a6dff8..996e3e4183a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=cvs-fast-export
-pkgver=1.48
+pkgver=1.49
pkgrel=1
pkgdesc="Export RCS or CVS history as a fastimport stream."
arch=('i686' 'x86_64')
@@ -9,8 +9,22 @@ depends=('python')
makedepends=('asciidoc')
url="http://www.catb.org/esr/$pkgname/"
license=('GPL2')
-source=("https://gitlab.com/esr/cvs-fast-export/-/archive/$pkgver/cvs-fast-export-$pkgver.tar.gz")
-sha512sums=('e260e281b3b0650ffff3882629cc96d964fc855b1fc72f9c8849e3e342acd91f2be07c0243915eac6286a936812cc1005e86079aaaeac2a150eba3c4b995b260')
+source=("https://gitlab.com/esr/cvs-fast-export/-/archive/$pkgver/cvs-fast-export-$pkgver.tar.gz"
+ 0001-Makefile-cflags-and-destdir.patch)
+sha512sums=('4e729c564800ed364b6d1bae8ffc2144e508e1a24677f5ab082843ce9d4263ea2ec80facbe0d1fdf59aabae6c4bf7cba30350517458400c98545a6853ad49f31'
+ '49c0a9fbe187a07dce9c5c7636aa7e48eaeff56fff9afb5f4e4e9930873a3bddccad112d0c05e8827a3c9bc1ece4867ace5682979762a0469c0774c2b195f93b')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
+}
build() {
cd "$pkgname-$pkgver"