summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Keenan2015-06-08 17:57:51 -0700
committerColin Keenan2015-06-08 17:57:51 -0700
commit551e9b1c4da4aae422ade559f8235a65911b9a2c (patch)
tree715dd046c51aa3634d3102be7e5a534297e2eac4
downloadaur-551e9b1c4da4aae422ade559f8235a65911b9a2c.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--tchrome.install22
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a60ae6612856
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tchrome
+ pkgdesc = Close Chrome browser including background, or launch a version of Google Chrome/Chromium
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/colinkeenan/tchrome
+ install = tchrome.install
+ arch = any
+ license = GPL
+ source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.2/tchrome
+ source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.2/tchrome.conf
+ source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.2/tchrome.desktop
+ md5sums = 45abeb3edac87aaa0980b48f01172937
+ md5sums = 3bab05dbc5357bbe934942503a79c6a3
+ md5sums = 7a6ae702e159c102ed888007e0f25358
+
+pkgname = tchrome
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bac8440af81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Colin Keenan <colinnkeenan at gmail dot com>
+
+pkgname=tchrome
+pkgver=1.2
+pkgrel=1
+pkgdesc="Close Chrome browser including background, or launch a version of Google Chrome/Chromium"
+arch=('any')
+url="https://github.com/colinkeenan/tchrome"
+license=('GPL')
+install=${pkgname}.install
+
+source=(https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}
+ https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}.conf
+ https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}.desktop)
+md5sums=('45abeb3edac87aaa0980b48f01172937'
+ '3bab05dbc5357bbe934942503a79c6a3'
+ '7a6ae702e159c102ed888007e0f25358')
+
+package() {
+ install -D -m644 ${pkgname}.conf "$pkgdir/etc/${pkgname}.conf"
+ install -D -m644 ${pkgname}.desktop "$pkgdir/usr/share/applications/${pkgname}.desktop"
+ install -D -m755 ${pkgname} "$pkgdir/usr/bin/${pkgname}"
+}
diff --git a/tchrome.install b/tchrome.install
new file mode 100644
index 000000000000..f19d53817061
--- /dev/null
+++ b/tchrome.install
@@ -0,0 +1,22 @@
+# Some colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+post_install() {
+ note "The script is named 'tchrome' and the desktop calls it 'Toggle Chrome (tchrome)'. This is meant to live on a panel in a launcher. Click to close all Chrome windows and background processes, or launch the version of the Chrome Browser specified in /etc/tchrome.conf if not already running. If running the scrip from the command line, make sure it runs from bash."
+}
+
+
+post_upgrade() {
+ post_install
+}