summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-29 12:55:07 +0100
committerJaroslav Lichtblau2014-11-29 12:55:07 +0100
commit552ac3b46e880d15e3d34ea5764aad7371c0a541 (patch)
tree55ab8f5c3ee3c9d69dd3e16da3907957e17265ac
parent20c2ffee915c978cc8c8416a480742606d2dc8d0 (diff)
downloadaur-552ac3b46e880d15e3d34ea5764aad7371c0a541.tar.gz
pngslice-0.66-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 070640c2d3db..eeb0c70cb601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = pngslice
- pkgdesc = The program performs this slicing for png images and writes a fragment of html to handle the image inclusion.
+ pkgdesc = Slice a png image for text-flow in html
pkgver = 0.66
- pkgrel = 1
- url = http://sview01.wiredworkplace.net/pub/jjg/en/code/pngslice.html
+ pkgrel = 2
+ url = http://download.openpkg.org/components/versioned/pngslice/
arch = i686
arch = x86_64
license = GPL
depends = libpng
- source = http://sview01.wiredworkplace.net/pub/jjg/code/pngslice.tar.gz
+ source = http://download.openpkg.org/components/versioned/pngslice/pngslice-20081018.tar.gz
md5sums = 816313410dee225f417765b1af0e6186
pkgname = pngslice
diff --git a/PKGBUILD b/PKGBUILD
index 508dc92839d4..b91ce2a46f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
-# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
pkgname=pngslice
pkgver=0.66
-pkgrel=1
-pkgdesc="The program performs this slicing for png images and writes a fragment of html to handle the image inclusion."
+pkgrel=2
+pkgdesc="Slice a png image for text-flow in html"
arch=('i686' 'x86_64')
-url="http://sview01.wiredworkplace.net/pub/jjg/en/code/pngslice.html"
+url="http://download.openpkg.org/components/versioned/pngslice/"
license=('GPL')
depends=('libpng')
-source=(http://sview01.wiredworkplace.net/pub/jjg/code/$pkgname.tar.gz)
-
+source=(http://download.openpkg.org/components/versioned/$pkgname/$pkgname-20081018.tar.gz)
md5sums=('816313410dee225f417765b1af0e6186')
build() {
cd "${srcdir}/$pkgname"
./configure --prefix=/usr
- make || return 1
-# doesn't work yet: make DESTDIR="${pgkdir}" install
+ make
+}
- install -D -m755 "src/$pkgname" "${pkgdir}/usr/bin/$pkgname" || return 1
- install -D -m644 "src/$pkgname.1" "${pkgdir}/usr/share/man/man1/$pkgname.1" || return 1
+package() {
+ cd "${srcdir}/$pkgname"
+
+# doesn't work yet: make DESTDIR="${pgkdir}" install
+ install -D -m755 src/$pkgname "${pkgdir}"/usr/bin/$pkgname
+ install -D -m644 src/$pkgname.1 "${pkgdir}"/usr/share/man/man1/$pkgname.1
}