summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2016-07-01 20:36:32 +0800
committerwenLiangcan2016-07-01 20:36:32 +0800
commit552c3823b670a4295d78c0e1df1a5efc2eea5542 (patch)
tree6c69c7ece3bfbe6e9c8e363e8c8644420edf9b13
downloadaur-552c3823b670a4295d78c0e1df1a5efc2eea5542.tar.gz
python2-cookiecheat 0.3.1-1.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD24
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af191685b7b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Jul 1 12:36:11 UTC 2016
+pkgbase = python2-cookiecheat
+ pkgdesc = Borrow cookies from your browser's authenticated session foruse in Python scripts.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/n8henrie/pycookiecheat
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/10/0e/4e1a6245876d431b160436fc5dc93d0d80f2d10f6d21938665f6d5da83c3/pycookiecheat-0.3.1.tar.gz
+ md5sums = 0d8c4b73f2c1f8561a58bb0b7ccbf0a5
+
+pkgname = python2-cookiecheat
+ depends = python2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..672880cfb03e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+### https://raw.github.com/github/gitignore/b27b46b656d026ac295b3a47cf43e8af192472e2/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15ca79f80307
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase=('python2-cookiecheat')
+pkgname=('python2-cookiecheat')
+_module='pycookiecheat'
+pkgver='0.3.1'
+pkgrel=1
+pkgdesc="Borrow cookies from your browser's authenticated session foruse in Python scripts."
+url="https://github.com/n8henrie/pycookiecheat"
+depends=('python2')
+makedepends=('python2-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/10/0e/4e1a6245876d431b160436fc5dc93d0d80f2d10f6d21938665f6d5da83c3/pycookiecheat-${pkgver}.tar.gz")
+md5sums=('0d8c4b73f2c1f8561a58bb0b7ccbf0a5')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}