summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Malaco2019-12-14 00:53:02 -0300
committerJonas Malaco2019-12-14 00:53:02 -0300
commit552e83616bd4bc973f2d118f2c291b78c9b099ee (patch)
tree2ee0302c8a36154013a00451b626be62ba949c81
parent7951af2a38a8c4bb327ba79e52dc35fe260b617e (diff)
downloadaur-552e83616bd4bc973f2d118f2c291b78c9b099ee.tar.gz
Update homepage/repository URLs and packaging
- update URLs to match the move to the pyusb org - simplify packaging matching official Community/python-pyusb - add gitignore - update maintainer
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD18
3 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45a83864d796..b733a163c471 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-pyusb-git
- pkgdesc = Easy USB access from Python
- pkgver = 1.0.2.r4.g3ec29ca
+ pkgdesc = USB access for Python
+ pkgver = 1.0.2.r28.ga0fd5f6
pkgrel = 1
- url = http://sourceforge.net/apps/trac/pyusb/
+ url = https://github.com/pyusb/pyusb
arch = any
license = BSD
makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
provides = python-pyusb
- source = pyusb::git+https://github.com/walac/pyusb
+ source = pyusb::git+https://github.com/pyusb/pyusb
md5sums = SKIP
pkgname = python-pyusb-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a8da84be3eb4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.SRCINFO
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 2555577ba90d..c824da1859e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer: Alex Forencich <alex@alexforencich.com>
+# Maintainer: Jonas Malaco <jonas@protocubo.io>
+# Contributor: Alex Forencich <alex@alexforencich.com>
pkgname=(python-pyusb-git python2-pyusb-git)
-pkgver=1.0.2.r4.g3ec29ca
-pkgrel=2
-pkgdesc="Easy USB access from Python"
+pkgver=1.0.2.r28.ga0fd5f6
+pkgrel=1
+pkgdesc="USB access for Python"
arch=('any')
-url="http://sourceforge.net/apps/trac/pyusb/"
+url="https://github.com/pyusb/pyusb"
license=('BSD')
makedepends=('git' 'python-setuptools' 'python2-setuptools')
provides=('python-pyusb')
-_gitroot='https://github.com/walac/pyusb'
+_gitroot='https://github.com/pyusb/pyusb'
_gitname='pyusb'
source=("$_gitname::git+$_gitroot")
@@ -30,7 +31,7 @@ package_python-pyusb-git() {
conflicts=('python-pyusb')
cd "$srcdir/$_gitname"
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/" --optimize=1
}
package_python2-pyusb-git() {
@@ -39,6 +40,5 @@ package_python2-pyusb-git() {
conflicts=('python2-pyusb')
cd "$srcdir/$_gitname"
- python2 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --optimize=1
}
-