summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-08-07 13:06:38 +0200
committerwillemw122021-08-07 13:06:38 +0200
commit553941931b58c065660e51eef21e7d438b2da510 (patch)
treee2035631ff5e997f836127e51810009c9430df35
parent69a78b8c0f4035b28ff326bb00b98c04dc94ae44 (diff)
downloadaur-553941931b58c065660e51eef21e7d438b2da510.tar.gz
Don't install hh. It is now an alias configuration
Add prepare(). Change source URL from git:// to git+https://. Remove branch=master Install Changelog and README.md. Remove hh conflict. Remove ncurses and readline dependencies. Update description. Update pkgver(). Minor edits.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD48
2 files changed, 33 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b93fd7d04a90..6e7476eb3059 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = hstr-git
- pkgdesc = A command line utility that brings improved bash/zsh command completion from the history. It aims to make completion easier and more efficient than Ctrl-r.
- pkgver = 2.3.r1.g1d82a22
+ pkgdesc = Bash and Zsh shell history suggest box - easily view, navigate, search and manage your command history
+ pkgver = 2.3.r3.g6507ac7
pkgrel = 1
url = https://github.com/dvorka/hstr
arch = x86_64
license = Apache
makedepends = git
- makedepends = readline
- makedepends = ncurses
- depends = readline
- conflicts = hh
- source = git://github.com/dvorka/hstr.git#branch=master
- md5sums = SKIP
+ provides = hstr
+ conflicts = hstr
+ source = hstr-git::git+https://github.com/dvorka/hstr.git
+ sha256sums = SKIP
pkgname = hstr-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 575beea815a6..f0fde8026636 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,43 @@
-# Maintainer: NicerSlicer <jans_coid at posteo dot de>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: NicerSlicer <jans_coid at posteo dot de>
# Contributor: Christian Wieden <wiedenchr at gmail dot com>
# Contributor: Ricardo Band <me at xengi dot de>
# Contributor: Filip SzymaƄski <fszymanski at, fedoraproject.org>
pkgname=hstr-git
-pkgver=2.3.r1.g1d82a22
+pkgver=2.3.r3.g6507ac7
pkgrel=1
-pkgdesc="A command line utility that brings improved bash/zsh command completion from the history. It aims to make completion easier and more efficient than Ctrl-r."
+pkgdesc="Bash and Zsh shell history suggest box - easily view, navigate, search and manage your command history"
arch=('x86_64')
url="https://github.com/dvorka/hstr"
license=('Apache')
-makedepends=('git' 'readline' 'ncurses')
-depends=('readline')
-source=(git://github.com/dvorka/hstr.git#branch=master)
-md5sums=('SKIP')
-conflicts=('hh');
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C $pkgname describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ sed -i "s|<ncursesw/curses.h>|<curses.h>|g" $pkgname/src/include/hstr{,_curses}.h
+}
build() {
- cd "hstr/build/tarball"
- ./tarball-automake.sh
- cd ../..
- sed -i -e "s#<ncursesw/curses.h>#<curses.h>#g" src/include/hstr_curses.h
- sed -i -e "s#<ncursesw/curses.h>#<curses.h>#g" src/include/hstr.h
- ./configure --prefix=/usr
- make
+ cd $pkgname/build/tarball
+ ./tarball-automake.sh
+
+ cd ../..
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "hstr"
- make DESTDIR="$pkgdir/" install
-}
+ install -Dm644 $pkgname/{Changelog,README.md} -t "$pkgdir/usr/share/doc/${pkgname%-git}"
-pkgver() {
- cd "hstr"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ make -C $pkgname DESTDIR="$pkgdir/" install
+ rm -f "$pkgdir/usr/bin/hh"
}
+