summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClément Martinez2018-08-15 17:40:08 +0200
committerClément Martinez2018-08-15 17:40:08 +0200
commit554839059c5b83628128a76931fe5fed42c92b5c (patch)
treebf1fd682ec81773ec5d4ebb1ea879845e0cea342
downloadaur-554839059c5b83628128a76931fe5fed42c92b5c.tar.gz
Version 1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5fd1a1758e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bagh-chal-gui
+ pkgdesc = A bagh-chal game with a SDL GUI.
+ pkgver = 1.0
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ depends = sdl2
+ depends = sdl2_ttf
+ depends = ttf-fira-sans
+ source = https://github.com/moverest/bagh-chal/archive/1.0.tar.gz
+ md5sums = c272cba13e72dde21e5140f5428d4de3
+
+pkgname = bagh-chal-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5907c15c9d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Clément Martinez <clementmartinezdev at gmail dot com>
+pkgname=bagh-chal-gui
+pkgver=1.0
+pkgrel=1
+pkgdesc="A bagh-chal game with a SDL GUI."
+arch=('x86_64')
+license=('MIT')
+depends=('sdl2' 'sdl2_ttf' 'ttf-fira-sans')
+source=("https://github.com/moverest/bagh-chal/archive/$pkgver.tar.gz")
+md5sums=('c272cba13e72dde21e5140f5428d4de3')
+
+
+build() {
+ cd "bagh-chal-$pkgver"
+ make "build/main_minimalist_sdl"
+}
+
+package() {
+ cd "bagh-chal-$pkgver"
+
+ bin_dir="$pkgdir/usr/bin"
+ mkdir -p "$bin_dir"
+ mv "build/main_minimalist_sdl" "$bin_dir/bagh-chal-minimalist-sdl"
+
+ launcher="$bin_dir/bagh-chal-gui"
+ echo -e "#!/bin/sh\n/usr/bin/bagh-chal-minimalist-sdl /usr/share/fonts/TTF/FiraSans-Regular.ttf" > "$launcher"
+ chmod +x "$launcher"
+}