summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-27 11:14:55 +1300
committercaltlgin2020-10-27 11:14:55 +1300
commit5560903ef123a589f0ed70433cda7fd82f3cb826 (patch)
tree15c6ba8e19b8d113c9f41b310a0498dd05862a02
parente39dedeab9e24e42a6afecc1cd28cae74f4a3291 (diff)
downloadaur-5560903ef123a589f0ed70433cda7fd82f3cb826.tar.gz
Refactored PKGBUILD
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5cad3bfd4d3..2d6053b1c30d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Louis Tim Larsen <louis(a)louis.dk>
-pkgname=xubuntu-community-artwork
+pkgname='xubuntu-community-artwork'
pkgver=20.04.0
pkgrel=2
pkgdesc='Xubuntu community wallpapers'
arch=('any')
url='https://launchpad.net/xubuntu-community-artwork'
+_pool_url='http://archive.ubuntu.com/ubuntu/pool/universe'
license=('custom')
-source=("http://archive.ubuntu.com/ubuntu/pool/universe/x/${pkgname}/${pkgname}_${pkgver}.tar.xz")
+# http://archive.ubuntu.com/ubuntu/pool/universe/x/xubuntu-community-artwork/
+source=("${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}.tar.xz")
sha256sums=('2a40074fae8754babc4e7c7e141ad2163f1f40cdf0e5ac6b267f432658d09dd1')
package() {
- install -Dm644 -t "${pkgdir}/usr/share/backgrounds/xfce" "${pkgname}/usr/share/xfce4/backdrops/"*.{jpg,png}
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}/README"
- install -Dm644 "${pkgname}/debian/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgname}"
+ install -Dvm644 "usr/share/xfce4/backdrops/"*.{'jpg','png'} -t "${pkgdir}/usr/share/backgrounds/xfce"
+ install -Dvm644 'README' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 "debian/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et: