summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhvalera2023-05-09 01:33:26 +0300
committerkhvalera2023-05-09 01:33:26 +0300
commit557e6d24fc300ea6c37f51851ff3443728e030c0 (patch)
tree1aa7306e858d3099162ac936df5770dd4bb9f1bb
parent227f52ee9857650937a05d43d4425a8b8ef8f46f (diff)
downloadaur-557e6d24fc300ea6c37f51851ff3443728e030c0.tar.gz
add 0007-fix-gcc-13.patch
-rw-r--r--.SRCINFO4
-rw-r--r--0007-fix-gcc-13.patch138
-rw-r--r--PKGBUILD11
3 files changed, 149 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02ada846d521..5f1dedef251b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bareos
pkgdesc = Bareos - Backup Archiving Recovery Open Sourced
pkgver = 22.0.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.bareos.org
arch = i686
arch = x86_64
@@ -29,6 +29,7 @@ pkgbase = bareos
source = 0004-sqlspam.patch
source = 0005-httpd.patch
source = 0006-hostname.patch
+ source = 0007-fix-gcc-13.patch
source = bootstrap-table-locale-all.min.js
md5sums = SKIP
md5sums = 419b0c64af750aa3e8ea668edf464d3e
@@ -37,6 +38,7 @@ pkgbase = bareos
md5sums = ca4c929a2462cafaead8d0b49e3cebed
md5sums = a6a260808e46c20b1c22aa2efebc3fe1
md5sums = 40fc1919d59133214466972b3f9aa6d2
+ md5sums = 19f8be5aec4e35b5b98f3f26af7c9d8a
md5sums = e78b88f897cfc3e60129eec360521e3d
pkgname = bareos-bconsole
diff --git a/0007-fix-gcc-13.patch b/0007-fix-gcc-13.patch
new file mode 100644
index 000000000000..a0b32879ccc2
--- /dev/null
+++ b/0007-fix-gcc-13.patch
@@ -0,0 +1,138 @@
+From 2bb7d74215bf6ae4f350de11bff04b68cf3c82b3 Mon Sep 17 00:00:00 2001
+From: Bruno Friedmann <bruno.friedmann@bareos.com>
+Date: Mon, 27 Mar 2023 13:22:11 +0200
+Subject: [PATCH] core: fixes for gcc-13 support
+
+- add explicit system_error and stdexcept
+- console_conf.cc fix std::move warning
+
+Signed-off-by: Bruno Friedmann <bruno.friedmann@bareos.com>
+---
+ core/src/cats/cats.h | 2 ++
+ core/src/console/console_conf.cc | 4 ++--
+ core/src/lib/thread_list.cc | 3 ++-
+ core/src/lib/thread_specific_data.cc | 3 ++-
+ core/src/lib/thread_specific_data.h | 3 ++-
+ core/src/lib/thread_specific_data_key.h | 4 +++-
+ 6 files changed, 13 insertions(+), 6 deletions(-)
+
+diff --git core/src/cats/cats.h.orig core/src/cats/cats.h
+index 7a6641b3f72..edb5ecbe38b 100644
+--- core/src/cats/cats.h.orig
++++ core/src/cats/cats.h
+@@ -41,6 +41,8 @@
+ #include "lib/output_formatter.h"
+
+ #include <string>
++#include <stdexcept>
++#include <system_error>
+ #include <vector>
+ template <typename T> class dlist;
+
+diff --git core/src/console/console_conf.cc.orig core/src/console/console_conf.cc
+index 9d3aecead2b..f0c0402744e 100644
+--- core/src/console/console_conf.cc.orig
++++ core/src/console/console_conf.cc
+@@ -3,7 +3,7 @@
+
+ Copyright (C) 2000-2009 Free Software Foundation Europe e.V.
+ Copyright (C) 2011-2012 Planets Communications B.V.
+- Copyright (C) 2013-2022 Bareos GmbH & Co. KG
++ Copyright (C) 2013-2023 Bareos GmbH & Co. KG
+
+ This program is Free Software; you can redistribute it and/or
+ modify it under the terms of version three of the GNU Affero General Public
+@@ -203,7 +203,7 @@ static bool SaveResource(int type, ResourceItem* items, int pass)
+ res_dir->resource_name_);
+ } else {
+ p->tls_cert_.allowed_certificate_common_names_
+- = std::move(p->tls_cert_.allowed_certificate_common_names_);
++ = std::move(res_dir->tls_cert_.allowed_certificate_common_names_);
+ }
+ break;
+ }
+diff --git core/src/lib/thread_list.cc.orig core/src/lib/thread_list.cc
+index 50aefb8ee2d..05607124a55 100644
+--- core/src/lib/thread_list.cc.orig
++++ core/src/lib/thread_list.cc
+@@ -1,7 +1,7 @@
+ /*
+ BAREOSĀ® - Backup Archiving REcovery Open Sourced
+
+- Copyright (C) 2019-2022 Bareos GmbH & Co. KG
++ Copyright (C) 2019-2023 Bareos GmbH & Co. KG
+
+ This program is Free Software; you can redistribute it and/or
+ modify it under the terms of version three of the GNU Affero General Public
+@@ -32,6 +32,7 @@
+ #include <memory>
+ #include <mutex>
+ #include <set>
++#include <system_error>
+ #include <thread>
+
+ static constexpr int debuglevel{800};
+diff --git core/src/lib/thread_specific_data.cc.orig core/src/lib/thread_specific_data.cc
+index 0953f5c125a..22a98c4a759 100644
+--- core/src/lib/thread_specific_data.cc.orig
++++ core/src/lib/thread_specific_data.cc
+@@ -3,7 +3,7 @@
+
+ Copyright (C) 2000-2012 Free Software Foundation Europe e.V.
+ Copyright (C) 2011-2012 Planets Communications B.V.
+- Copyright (C) 2019-2019 Bareos GmbH & Co. KG
++ Copyright (C) 2019-2023 Bareos GmbH & Co. KG
+
+ This program is Free Software; you can redistribute it and/or
+ modify it under the terms of version three of the GNU Affero General Public
+@@ -25,6 +25,7 @@
+ #include "lib/thread_specific_data.h"
+ #include "lib/thread_specific_data_key.h"
+ #include "include/jcr.h"
++#include <system_error>
+
+ JobControlRecord* GetJcrFromThreadSpecificData()
+ {
+diff --git core/src/lib/thread_specific_data.h.orig core/src/lib/thread_specific_data.h
+index 4bd4dedafae..4c427d171c0 100644
+--- core/src/lib/thread_specific_data.h.orig
++++ core/src/lib/thread_specific_data.h
+@@ -3,7 +3,7 @@
+
+ Copyright (C) 2000-2012 Free Software Foundation Europe e.V.
+ Copyright (C) 2011-2012 Planets Communications B.V.
+- Copyright (C) 2019-2021 Bareos GmbH & Co. KG
++ Copyright (C) 2019-2023 Bareos GmbH & Co. KG
+
+ This program is Free Software; you can redistribute it and/or
+ modify it under the terms of version three of the GNU Affero General Public
+@@ -24,6 +24,7 @@
+ #ifndef BAREOS_LIB_THREAD_SPECIFIC_DATA_H_
+ #define BAREOS_LIB_THREAD_SPECIFIC_DATA_H_
+
++
+ class JobControlRecord;
+
+ JobControlRecord* GetJcrFromThreadSpecificData();
+diff --git core/src/lib/thread_specific_data_key.h.orig core/src/lib/thread_specific_data_key.h
+index 9c02c07f47e..c8c63c757fe 100644
+--- core/src/lib/thread_specific_data_key.h.orig
++++ core/src/lib/thread_specific_data_key.h
+@@ -1,7 +1,7 @@
+ /*
+ BAREOSĀ® - Backup Archiving REcovery Open Sourced
+
+- Copyright (C) 2019-2021 Bareos GmbH & Co. KG
++ Copyright (C) 2019-2023 Bareos GmbH & Co. KG
+
+ This program is Free Software; you can redistribute it and/or
+ modify it under the terms of version three of the GNU Affero General Public
+@@ -22,6 +22,8 @@
+ #ifndef BAREOS_LIB_THREAD_SPECIFIC_DATA_KEY_H_
+ #define BAREOS_LIB_THREAD_SPECIFIC_DATA_KEY_H_
+
++
++#include <system_error>
+ #include "lib/berrno.h"
+
+ #include <mutex>
diff --git a/PKGBUILD b/PKGBUILD
index a005a40bf009..97cc0e0d66cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,7 +50,7 @@ pkgname=("bareos-bconsole"
pkgver=22.0.3
pkgmajor=${pkgver%%.*}
-pkgrel=1
+pkgrel=2
arch=(i686 x86_64 armv7h aarch64)
groups=('bareos')
pkgdesc="Bareos - Backup Archiving Recovery Open Sourced"
@@ -65,6 +65,7 @@ source=("git+https://github.com/bareos/bareos.git#tag=Release/${pkgver}"
"0004-sqlspam.patch"
"0005-httpd.patch"
"0006-hostname.patch"
+ "0007-fix-gcc-13.patch"
"bootstrap-table-locale-all.min.js")
md5sums=('SKIP'
@@ -74,7 +75,9 @@ md5sums=('SKIP'
'ca4c929a2462cafaead8d0b49e3cebed'
'a6a260808e46c20b1c22aa2efebc3fe1'
'40fc1919d59133214466972b3f9aa6d2'
- 'e78b88f897cfc3e60129eec360521e3d')
+ '19f8be5aec4e35b5b98f3f26af7c9d8a'
+ 'e78b88f897cfc3e60129eec360521e3d'
+ )
python3_ver="3.10"
#python2_ver="2.7"
@@ -136,7 +139,9 @@ build() {
-Dfd-group=root \
-Dscsi-crypto=yes \
-Dsystemd=yes \
- -Dtraymonitor=yes
+ -Dtraymonitor=yes \
+ -DCMAKE_CXX_FLAGS="-Wno-use-after-free" \
+ -DCMAKE_C_FLAGS="-Wno-use-after-free"
make DESTDIR="${srcdir}/install" install