summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-03-20 00:19:04 +0100
committerChristopher Arndt2022-03-20 00:19:04 +0100
commit5586407db029e269c3a2c867af30c86182a71100 (patch)
treeae09bc0b1e33c1f14b6a2954f0ebbad8785472d9
parenta27a77a639d3207be7d32de7195226a09facedf4 (diff)
downloadaur-5586407db029e269c3a2c867af30c86182a71100.tar.gz
New upstream version 0.2.1
Also add 'check' function
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
2 files changed, 25 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fb677492808..d480d4af30df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = midiomatic
pkgdesc = A collection of MIDI filter, generator and processor LV2 and VST plugins
- pkgver = 0.2.0
- pkgrel = 2
+ pkgver = 0.2.1
+ pkgrel = 1
url = https://github.com/SpotlightKid/midiomatic
- arch = i686
arch = x86_64
groups = pro-audio
groups = lv2-plugins
groups = vst-plugins
license = MIT
+ checkdepends = kxstudio-lv2-extensions
+ checkdepends = lv2lint
depends = gcc-libs
- source = https://github.com/SpotlightKid/midiomatic/releases/download/v0.2.0/midiomatic-0.2.0.tar.gz
- sha256sums = 06be064b2868a6ba140f7bc8d4ef7b7e675454dd7ef5b5c54e22e8ccf8e77628
+ source = https://github.com/SpotlightKid/midiomatic/releases/download/v0.2.1/midiomatic-0.2.1.tar.gz
+ sha256sums = aed203bde8fd01e279e058d48f084754f50b9fd758d7b56b845f11d8fbdbb1f3
pkgname = midiomatic
-
diff --git a/PKGBUILD b/PKGBUILD
index 6fdd6edda5bf..9dd77dacb2b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
-_pkgver="0.2.0"
pkgname=midiomatic
-pkgver=${_pkgver//-/_}
-pkgrel=2
+pkgver="0.2.1"
+pkgrel=1
pkgdesc="A collection of MIDI filter, generator and processor LV2 and VST plugins"
-arch=('i686' 'x86_64')
+arch=(x86_64)
url="https://github.com/SpotlightKid/midiomatic"
-license=('MIT')
-groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
-depends=('gcc-libs')
+license=(MIT)
+groups=(pro-audio lv2-plugins vst-plugins)
+depends=(gcc-libs)
+checkdepends=(kxstudio-lv2-extensions lv2lint)
source=(
- "https://github.com/SpotlightKid/midiomatic/releases/download/v${_pkgver}/${pkgname}-${_pkgver}.tar.gz"
+ "https://github.com/SpotlightKid/midiomatic/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
)
-sha256sums=('06be064b2868a6ba140f7bc8d4ef7b7e675454dd7ef5b5c54e22e8ccf8e77628')
-
+sha256sums=('aed203bde8fd01e279e058d48f084754f50b9fd758d7b56b845f11d8fbdbb1f3')
build() {
- cd "${srcdir}/${pkgname}-${_pkgver}"
-
+ cd "$pkgname-$pkgver"
make
}
-package() {
- cd "${srcdir}/${pkgname}-${_pkgver}"
+check() {
+ cd "$pkgname-$pkgver"
+ make check
+}
+package() {
+ cd "$pkgname-$pkgver"
# install plugin LV2 bundles and VST binaries
- make PREFIX=/usr DESTDIR="${pkgdir}" install
-
+ make PREFIX=/usr DESTDIR="$pkgdir" install
# readme
- install -Dm644 README.md -t "${pkgdir}"/usr/share/doc/${pkgname}
-
+ install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
# license file
- install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}