summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelip Manyer i Ballester2015-08-07 17:29:09 +0200
committerFelip Manyer i Ballester2015-08-07 17:29:09 +0200
commit55960fa57500e479d97f4db8fb4eda4ee6f05faf (patch)
tree4b1e66b9b71b9327b32cb459ac027711853653c4
downloadaur-55960fa57500e479d97f4db8fb4eda4ee6f05faf.tar.gz
Migrated vim-omlet to AUR4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--vimdoc.install26
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6413f97333ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-omlet
+ pkgdesc = Much better OCaml indentation, and more
+ pkgver = 0.13
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=1196
+ install = vimdoc.install
+ arch = i686
+ arch = x86_64
+ groups = vim-plugins
+ license = GPL2
+ depends = vim
+ source = http://www.vim.org/scripts/download_script.php?src_id=4135
+ md5sums = 3f4781f25002862ad1af07008bd7fbc1
+
+pkgname = vim-omlet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cae12fcc5fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Florian Plaza Onate <florian dot plaza at gmail dot com>
+# Contributor: Laszlo Papp <djszapi at gmail dot com>
+pkgname=vim-omlet
+pkgver=0.13
+_scriptid=4135
+pkgrel=1
+pkgdesc="Much better OCaml indentation, and more"
+arch=(i686 x86_64)
+url="http://www.vim.org/scripts/script.php?script_id=1196"
+license=('GPL2')
+depends=(vim)
+groups=('vim-plugins')
+install=vimdoc.install
+source=(http://www.vim.org/scripts/download_script.php?src_id=${_scriptid})
+md5sums=('3f4781f25002862ad1af07008bd7fbc1')
+
+build() {
+ _vim_dir=usr/share/vim/vimfiles
+
+ install -d ${pkgdir}/${_vim_dir}/{ftdetect,ftplugin,indent,syntax}
+
+ cd ${srcdir}/omlet-${pkgver}/
+
+ for _i in ftdetect ftplugin indent syntax; do
+ install -Dm755 ${_i}/* ${pkgdir}/${_vim_dir}/${_i}/ || return 1
+ done
+}
+
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..e8d965fa1d39
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,26 @@
+update_tags() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo " done."
+}
+
+post_install() {
+ update_tags $1
+ echo "Add lines like \"filetype plugin on\", \"filetype indent on\" to your .vimrc"
+ echo "in order to enable OMLet."
+}
+
+
+post_upgrade() {
+ update_tags $1
+}
+
+post_remove() {
+ update_tags $1
+}
+
+op=$1
+shift
+
+$op $*