summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralium2020-05-19 16:41:47 +0200
committeralium2020-05-19 16:41:47 +0200
commit5598178da142001b88c0fd206fa0d9329f6ce13a (patch)
tree8a6a09537d3f50b05b55fb35d12c443d837f6cb1
parentb463ac6e6885400fc9c0a967311ba94bbb38e7b2 (diff)
downloadaur-5598178da142001b88c0fd206fa0d9329f6ce13a.tar.gz
Prepare new tarball + added fix gcc10
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--gcc10-2.patch27
-rw-r--r--gcc10.patch29
4 files changed, 71 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b28e8b2b9b4..38372228e578 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,8 +17,12 @@ pkgbase = libva-intel-driver-g45-h264
conflicts = libva-intel-driver
conflicts = intel-gpu-tools
replaces = libva-intel-driver
- source = https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-2.4.0.tar.gz
- sha256sums = de7b15188bb3bf4892363c007d6b2fb6121e5682f337428a0a6316face62cc5e
+ source = https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-2.4.0-2.tar.gz
+ source = gcc10.patch
+ source = gcc10-2.patch
+ sha256sums = 6850c0e519b09bd720bab8bdbf8e53974c44fec7ebca7389990cd1262ce35f09
+ sha256sums = ca9db2bace98932deadc1301d57194b8ad777ecb43b31b10e76b2b6b1ac2bfd9
+ sha256sums = f87c8398a26faf50fa23769a3bbbedb865ced964a2257a14211eb3434c4a5658
pkgname = libva-intel-driver-g45-h264
diff --git a/PKGBUILD b/PKGBUILD
index eb7b1525b941..d06298136f9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,13 +17,18 @@ optdepends=('libva-utils: Applications and Scripts for libva (vainfo and others)
license=(MIT)
makedepends=(mesa)
-source=(https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-$pkgver.tar.gz)
+source=(https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-$pkgver-2.tar.gz
+ gcc10.patch gcc10-2.patch)
prepare () {
cd intel-vaapi-driver
# Only relevant if intel-gpu-tools is installed,
# since then the shaders will be recompiled
sed -i '1s/python$/&2/' src/shaders/gpp.py
+
+ # fix gcc10 errors
+ patch -Np1 -i ../gcc10.patch
+ patch -Np1 -i ../gcc10-2.patch
}
build() {
@@ -39,4 +44,6 @@ package() {
install -m644 -D COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
}
-sha256sums=('de7b15188bb3bf4892363c007d6b2fb6121e5682f337428a0a6316face62cc5e')
+sha256sums=('6850c0e519b09bd720bab8bdbf8e53974c44fec7ebca7389990cd1262ce35f09'
+ 'ca9db2bace98932deadc1301d57194b8ad777ecb43b31b10e76b2b6b1ac2bfd9'
+ 'f87c8398a26faf50fa23769a3bbbedb865ced964a2257a14211eb3434c4a5658')
diff --git a/gcc10-2.patch b/gcc10-2.patch
new file mode 100644
index 000000000000..2fa8e7fbd5b6
--- /dev/null
+++ b/gcc10-2.patch
@@ -0,0 +1,27 @@
+From 10b74f1b4ab9a742d98f81aad57399ff682975a4 Mon Sep 17 00:00:00 2001
+From: "U. Artie Eoff" <ullysses.a.eoff@intel.com>
+Date: Tue, 12 May 2020 11:03:26 -0700
+Subject: [PATCH] test: cast VA_STATSUS_ERROR_UNKNOWN to VAStatus
+
+This fixes a gcc10 compiler error for the
+VA_STATUS_ERROR_UNKNOWN 0xFFFFFFFF conversion from
+unsigned int to int.
+
+Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com>
+---
+ test/test.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/test.h b/test/test.h
+index 5d3fdc8c..fc23ad12 100644
+--- a/test/test.h
++++ b/test/test.h
+@@ -147,7 +147,7 @@ class VaapiStatus
+ status = "VA_STATUS_ERROR_HW_BUSY"; break;
+ case VA_STATUS_ERROR_UNSUPPORTED_MEMORY_TYPE:
+ status = "VA_STATUS_ERROR_UNSUPPORTED_MEMORY_TYPE"; break;
+- case VA_STATUS_ERROR_UNKNOWN:
++ case VAStatus(VA_STATUS_ERROR_UNKNOWN):
+ status = "VA_STATUS_ERROR_UNKNOWN"; break;
+ default:
+ status = "Unknown VAStatus";
diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644
index 000000000000..1f243de1e006
--- /dev/null
+++ b/gcc10.patch
@@ -0,0 +1,29 @@
+From fc1c4ac1422cbb416817eb37af7d7007b97b8ec0 Mon Sep 17 00:00:00 2001
+From: "U. Artie Eoff" <ullysses.a.eoff@intel.com>
+Date: Tue, 12 May 2020 11:01:30 -0700
+Subject: [PATCH] Fix HEVCe kernel compile error on gcc10
+
+This fixes a "multiple definition" compiler error on
+gcc10 which defaults to -fno-common.
+
+https://gcc.gnu.org/gcc-10/porting_to.html#common
+
+Fixes #503
+
+Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com>
+---
+ src/gen9_hevc_enc_kernels_binary.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gen9_hevc_enc_kernels_binary.h b/src/gen9_hevc_enc_kernels_binary.h
+index 29659fa0..ff7d0af5 100644
+--- a/src/gen9_hevc_enc_kernels_binary.h
++++ b/src/gen9_hevc_enc_kernels_binary.h
+@@ -31,6 +31,6 @@
+
+ #define GEN9_HEVC_ENC_KERNEL_SIZE 149296
+
+-const unsigned int gen9_hevc_encoder_kernels[GEN9_HEVC_ENC_KERNEL_SIZE];
++extern const unsigned int gen9_hevc_encoder_kernels[GEN9_HEVC_ENC_KERNEL_SIZE];
+
+ #endif