summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-09 13:23:00 +0300
committerDimitris Kiziridis2020-04-09 13:23:00 +0300
commit559a294f67660a0266d7df4804e6a7be9ad9cb01 (patch)
tree079c05c50ca96e0537e9e1c17779e2189c8d65fe
downloadaur-559a294f67660a0266d7df4804e6a7be9ad9cb01.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88f98ca61091
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = timetrap
+ pkgdesc = Timetrap is a simple command line time tracker written in ruby. It provides an easy to use command line interface for tracking what you spend your time on
+ pkgver = 1.15.2
+ pkgrel = 1
+ url = https://github.com/samg/timetrap
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-chronic
+ depends = ruby-sequel
+ depends = ruby-sqlite3
+ noextract = $pkgname-$pkgver.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/timetrap-1.15.2.gem
+ md5sums = c7c84dc593201b1764268ca46dc06c2c
+
+pkgname = timetrap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c29c6712a3d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=timetrap
+pkgver=1.15.2
+pkgrel=1
+pkgdesc='Timetrap is a simple command line time tracker written in ruby. It provides an easy to use command line interface for tracking what you spend your time on'
+arch=('any')
+url='https://github.com/samg/timetrap'
+license=('MIT')
+depends=('ruby'
+ 'ruby-chronic'
+ 'ruby-sequel'
+ 'ruby-sqlite3')
+options=('!emptydirs')
+source=("https://rubygems.org/downloads/$pkgname-$pkgver.gem")
+noextract=('$pkgname-$pkgver.gem')
+md5sums=('c7c84dc593201b1764268ca46dc06c2c')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $pkgname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$pkgname-$pkgver.gem"
+} \ No newline at end of file