summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Griffis2016-04-03 17:43:35 -0400
committerPatrick Griffis2016-04-03 17:43:35 -0400
commit55a0d0831b4fd9c332a083c0b6540f5648de9e4f (patch)
treec5762047a2a3c35505302922fdff58b8a684d488
downloadaur-55a0d0831b4fd9c332a083c0b6540f5648de9e4f.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
-rw-r--r--sysprof2.install13
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a959acdff8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = sysprof2-git
+ pkgdesc = CPU Profiler
+ pkgver = 1.99.0.gabbf2e0
+ pkgrel = 1
+ url = https://github.com/chergert/sysprof2
+ install = sysprof2.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL3
+ makedepends = intltool
+ makedepends = git
+ makedepends = autoconf-archive
+ depends = gtk3
+ depends = polkit
+ provides = sysprof2
+ conflicts = sysprof2
+ options = !libtool
+ source = git+https://github.com/chergert/sysprof2.git
+ md5sums = SKIP
+
+pkgname = sysprof2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29d9ef56fa1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: TingPing tingping@tingping.se
+
+pkgname=sysprof2-git
+pkgver=1.99.0.gabbf2e0
+pkgrel=1
+pkgdesc='CPU Profiler'
+arch=('i686' 'x86_64' 'armv6h')
+url='https://github.com/chergert/sysprof2'
+license=('GPL3')
+options=('!libtool')
+depends=('gtk3' 'polkit')
+makedepends=('intltool' 'git' 'autoconf-archive')
+install='sysprof2.install'
+provides=('sysprof2')
+conflicts=('sysprof2')
+source=('git+https://github.com/chergert/sysprof2.git')
+md5sums=('SKIP')
+_gitname='sysprof2'
+
+pkgver() {
+ cd "$_gitname"
+
+ # TODO
+ _ver='1.99.0'
+ _hash=`git describe --always`
+ echo "$_ver.g$_hash"
+}
+
+build() {
+ cd "$_gitname"
+
+ ./autogen.sh --prefix=/usr --disable-debug
+ make -s
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/sysprof2.install b/sysprof2.install
new file mode 100644
index 000000000000..c25db12801ae
--- /dev/null
+++ b/sysprof2.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}