summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2017-11-23 22:08:49 +0000
committerEarnestly2017-11-23 22:08:49 +0000
commit55b82ee621eb5f9e2bd92bf145c6d76a0faf6781 (patch)
tree00d03dbace8eb860aec6e932fd08ef62ecd241ba
downloadaur-55b82ee621eb5f9e2bd92bf145c6d76a0faf6781.tar.gz
add headmaster
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c55e59745a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = headmaster-git
+ pkgdesc = translate c header files to another language
+ pkgver = 0.27.r55.gf6a265e
+ pkgrel = 1
+ url = https://github.com/ytomino/headmaster
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = ocamlbuild
+ makedepends = python-docutils
+ depends = mpfr
+ options = !makeflags
+ source = git+https://github.com/ytomino/headmaster
+ source = git+https://github.com/ytomino/gmp-ocaml
+ source = git+https://github.com/ytomino/unicode-ocaml
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = headmaster-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4d549b220ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=headmaster-git
+pkgver=0.27.r55.gf6a265e
+pkgrel=1
+
+pkgdesc='translate c header files to another language'
+url='https://github.com/ytomino/headmaster'
+arch=('i686' 'x86_64')
+license=('BSD')
+
+# XXX -jN where N > 1 causes race condition failures
+options=('!makeflags')
+
+depends=('mpfr')
+makedepends=('git' 'ocamlbuild' 'python-docutils')
+
+source=('git+https://github.com/ytomino/headmaster'
+ 'git+https://github.com/ytomino/gmp-ocaml'
+ 'git+https://github.com/ytomino/unicode-ocaml')
+
+sha256sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd headmaster
+ git describe --long --tags | sed -r 's/^v//; s/([^-]*-g)/r\1/; s/-/./g'
+}
+
+prepare() {
+ cd headmaster
+ git submodule init
+ git config submodule.lib/gmp-ocaml.url "$srcdir"/gmp-ocaml
+ git config submodule.lib/unicode-ocaml.url "$srcdir"/unicode-ocaml
+ git submodule update lib/gmp-ocaml lib/unicode-ocaml
+}
+
+build() {
+ cd headmaster/main
+ make
+}
+
+package() {
+ cd headmaster
+ install -Dm0755 main/bin/main.native "$pkgdir"/usr/bin/headmaster
+ install -Dm0644 main/man1/headmaster.1 "$pkgdir"/usr/share/man/man1/headmaster.1
+ install -Dm0644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}