summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 15:23:19 +0200
committerPiotr Rogoża2015-06-14 15:23:19 +0200
commit55baef13475a35a7f06bc65ffcead5e218c8ec25 (patch)
treed6a1001212944d0f9427218e407ff23447c6a8a5
downloadaur-55baef13475a35a7f06bc65ffcead5e218c8ec25.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD71
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..658c38bdf5c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-devel-smallprof
+ pkgdesc = Devel::SmallProf - Per-line Perl profiler
+ pkgver = 2.02
+ pkgrel = 3
+ url = http://search.cpan.org/dist/Devel-SmallProf/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/S/SA/SALVA/Devel-SmallProf-2.02.tar.gz
+ md5sums = 498704ed1b888fc62b0c7092f8b590f5
+
+pkgname = perl-devel-smallprof
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec1bfdff3af7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+
+_author=S/SA/SALVA
+_perlmod=Devel-SmallProf
+pkgname=perl-devel-smallprof
+pkgver=2.02
+pkgrel=3
+pkgdesc="Devel::SmallProf - Per-line Perl profiler"
+arch=('any')
+url="http://search.cpan.org/dist/Devel-SmallProf/"
+license=('GPL' 'PerlArtistic')
+groups=()
+depends=('perl>=5.10.0')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+noextract=()
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+md5sums=('498704ed1b888fc62b0c7092f8b590f5')