summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConor Anderson2017-11-05 12:51:20 -0500
committerConor Anderson2017-11-05 12:51:20 -0500
commit55bfc425aa6611f6095006dac8049730952ad61f (patch)
treec53ee7ae1b82b8a3b7a634cc086c1e9f3c63ad87
parenta74f5362ce5da29dc75eb007eb1a96ec354a9130 (diff)
downloadaur-55bfc425aa6611f6095006dac8049730952ad61f.tar.gz
Tweaks
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
-rw-r--r--lighttable.desktop9
3 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d2d5cf4f962..5a4fb06070f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = lighttable-git
pkgdesc = Next generation code editor and IDE with instant feedback.
- pkgver = 0.8.1.r39.g183b485
+ pkgver = 0.8.1.r49.g5db6b70
pkgrel = 1
url = http://lighttable.com/
arch = x86_64
arch = i686
license = MIT
- makedepends = gendesk
makedepends = npm
makedepends = leiningen
depends = alsa-lib
@@ -18,9 +17,11 @@ pkgbase = lighttable-git
depends = nss
depends = libxtst
provides = lighttable
- conflicts = lighttable
+ conflicts = lighttable-bin
source = git://github.com/LightTable/LightTable.git
+ source = lighttable.desktop
sha256sums = SKIP
+ sha256sums = 3ed905cba2906c138016e53d9b9327bf933c8e96f649b50b3a479ec32045d1e1
pkgname = lighttable-git
diff --git a/PKGBUILD b/PKGBUILD
index b095cdee1570..15a6a0de27bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,27 @@
pkgname=lighttable-git
_pkgname="${pkgname%-git}"
_name=LightTable
-pkgver=0.8.1.r39.g183b485
+pkgver=0.8.1.r49.g5db6b70
_pkgver=${pkgver/%.r*/}
pkgrel=1
pkgdesc='Next generation code editor and IDE with instant feedback.'
arch=('x86_64' 'i686')
url='http://lighttable.com/'
license=('MIT')
-conflicts=('lighttable')
+conflicts=('lighttable-bin')
depends=('alsa-lib' 'gconf' 'gtk2' 'java-environment' 'libnotify' 'nodejs' 'nss' 'libxtst')
-makedepends=('gendesk' 'npm' 'leiningen')
+makedepends=('npm' 'leiningen')
provides=('lighttable')
-source=("git://github.com/LightTable/LightTable.git")
-sha256sums=('SKIP')
+source=("git://github.com/LightTable/LightTable.git"
+ "lighttable.desktop")
+sha256sums=('SKIP'
+ '3ed905cba2906c138016e53d9b9327bf933c8e96f649b50b3a479ec32045d1e1')
pkgver() {
cd "${srcdir}/${_name}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- gendesk -f -n --name="${_name}" --pkgname="${_pkgname}" --pkgdesc="${pkgdesc}" --exec="${_pkgname}" --categories="Development"
-}
-
build() {
cd "${srcdir}/${_name}"
script/build.sh
@@ -40,7 +38,7 @@ package() {
ln -s "/usr/lib/${_pkgname}/${_name}" "${pkgdir}/usr/bin/${_pkgname}"
# Place desktop entry and icon
- desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${srcdir}/${_pkgname}.desktop"
+ desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${_pkgname}.desktop"
install -Dm644 "${srcdir}/${_name}/deploy/core/img/lticon.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
# Place license files
diff --git a/lighttable.desktop b/lighttable.desktop
new file mode 100644
index 000000000000..f5d62a5c12ce
--- /dev/null
+++ b/lighttable.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Light Table
+Comment=Light Table IDE
+Type=Application
+Icon=lighttable
+Exec=lighttable
+Categories=Utility;TextEditor;Development
+Terminal=false
+MimeType=text/plain;