summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenGi2017-11-28 16:16:23 +0100
committerXenGi2017-11-28 16:16:23 +0100
commit55f2460c562b9fa602e9b1d6b0895d29e530db86 (patch)
treeb175262df568c09fb10c64e63212fd3e4ba1dd14
downloadaur-55f2460c562b9fa602e9b1d6b0895d29e530db86.tar.gz
initial release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e125df48f49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-speeed
+ pkgdesc = Ping like tool that measures packet speed instead of response time
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/xengi/speeed
+ arch = any
+ license = MIT
+ depends = python-setuptools
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/s/speeed/speeed-1.0.0.tar.gz
+ sha1sums = 6f8fa71806213df4c1693da4474a085f3900dece
+
+pkgname = python-speeed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2efb25b6f8cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Ricardo (XenGi) Band <email@ricardo.band>
+pkgname='python-speeed'
+_name='speeed'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Ping like tool that measures packet speed instead of response time"
+arch=(any)
+url="https://github.com/xengi/speeed"
+license=('MIT')
+depends=('python-setuptools')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha1sums=('6f8fa71806213df4c1693da4474a085f3900dece')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+