summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrouhannb2019-01-26 16:36:28 -0500
committerrouhannb2019-01-26 16:36:28 -0500
commit55f9addbc2aec51d331e947c2edcd35f0f648be1 (patch)
tree5db8f7df96f40db457c45e1cd94681490365fe32
downloadaur-55f9addbc2aec51d331e947c2edcd35f0f648be1.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--runner.sh2
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc0c1daa9991
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fusee-launcher-git
+ pkgdesc = work-in-progress launcher for one of the Tegra X1 bootROM exploits
+ pkgver = r30.265e8f3
+ pkgrel = 1
+ url = https://github.com/Cease-and-DeSwitch/fusee-launcher
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = arm-none-eabi-gcc
+ depends = python-pyusb
+ provides = fusee-launcher
+ conflicts = fusee-launcher
+ source = git+https://github.com/Cease-and-DeSwitch/fusee-launcher.git
+ source = runner.sh
+ md5sums = SKIP
+ md5sums = 1d81a0959d6f81c94caca58d3496ba7b
+
+pkgname = fusee-launcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e77e00d0ed53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: rouhannb <rouhannb@gmail.com>
+pkgname=fusee-launcher-git
+pkgver=r30.265e8f3
+pkgrel=1
+pkgdesc='work-in-progress launcher for one of the Tegra X1 bootROM exploits'
+arch=('any')
+url="https://github.com/Cease-and-DeSwitch/${pkgname%-git}"
+license=('GPL2')
+depends=('python-pyusb')
+makedepends=('git' 'arm-none-eabi-gcc')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/Cease-and-DeSwitch/fusee-launcher.git' 'runner.sh')
+md5sums=('SKIP' '1d81a0959d6f81c94caca58d3496ba7b')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# This isn't truly necessary, as fusee-launcher comes with a precompiled
+# intermezzo.bin. Running makepkg with --nobuild should work fine.
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm644 -t "$pkgdir/opt/${pkgname%-git}" "${pkgname%-git}.py"
+ install -m644 -t "$pkgdir/opt/${pkgname%-git}" 'intermezzo.bin'
+ install -D "$srcdir/runner.sh" "$pkgdir/usr/bin/${pkgname%-git}"
+}
diff --git a/runner.sh b/runner.sh
new file mode 100644
index 000000000000..5f90fcf3d525
--- /dev/null
+++ b/runner.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+python3 '/opt/fusee-launcher/fusee-launcher.py' "$@"