summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmcdougall2015-10-31 13:39:53 -0400
committersmcdougall2015-10-31 13:39:53 -0400
commit55fbb215a119cae001ae410ae5c7d8727676ed85 (patch)
treec73d45365c550f0b617b17ca1519256be5c8b27a
downloadaur-55fbb215a119cae001ae410ae5c7d8727676ed85.tar.gz
Initial Release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
-rw-r--r--plymouth-theme-arch-charge-big.install12
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c012f9c2c99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = plymouth-theme-arch-charge-big
+ pkgdesc = A Plyouth theme based on Fedora's Charge theme, but featuring the ArchLinux logo. This version has a larger logo than the regular variant.
+ pkgver = 20151031
+ pkgrel = 1
+ url = http://development.sjmcdougall.com/plymouth-themes/arch-charge-big
+ install = plymouth-theme-arch-charge-big.install
+ arch = any
+ license = GPL
+ depends = plymouth
+ source = plymouth-theme-arch-charge-big-src.tar.gz::http://development.sjmcdougall.com/plymouth-themes/content/arch-charge-big/plymouth-theme-arch-charge-big-src.tar.gz
+ source = plymouth-theme-arch-charge-big.install
+ md5sums = 7b61242549e4a331ffee1695aa06a49d
+ md5sums = 54ebc03f22123a5c971cefbb3a3fe35c
+
+pkgname = plymouth-theme-arch-charge-big
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09cc4411c5b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Maintainer: smcdougall <simon at sjmcdougall dot com>
+
+pkgname=plymouth-theme-arch-charge-big
+pkgver=20151031
+pkgrel=1
+pkgdesc="A Plyouth theme based on Fedora's Charge theme, but featuring the ArchLinux logo. This version has a larger logo than the regular variant."
+arch=('any')
+url="http://development.sjmcdougall.com/plymouth-themes/arch-charge-big"
+license=('GPL')
+depends=('plymouth')
+
+install='plymouth-theme-arch-charge-big.install'
+source=('plymouth-theme-arch-charge-big-src.tar.gz::http://development.sjmcdougall.com/plymouth-themes/content/arch-charge-big/plymouth-theme-arch-charge-big-src.tar.gz'
+ 'plymouth-theme-arch-charge-big.install')
+md5sums=('7b61242549e4a331ffee1695aa06a49d'
+ '54ebc03f22123a5c971cefbb3a3fe35c')
+
+package() {
+ cd $srcdir/${pkgname}
+ mkdir -p $pkgdir/usr/share/plymouth/themes/arch-charge-big
+ install -Dm644 * "${pkgdir}"/usr/share/plymouth/themes/arch-charge-big
+}
+
diff --git a/plymouth-theme-arch-charge-big.install b/plymouth-theme-arch-charge-big.install
new file mode 100644
index 000000000000..11dcac67991a
--- /dev/null
+++ b/plymouth-theme-arch-charge-big.install
@@ -0,0 +1,12 @@
+post_install() {
+ cat << _EOF
+
+==> To activate run:
+==> sudo plymouth-set-default-theme -R arch-charge-big
+
+_EOF
+}
+
+post_upgrade() {
+ post_install $1
+}