summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 22:00:25 +0200
committerJerome Leclanche2015-06-09 22:00:25 +0200
commit560f9e4432adba991f318db91bb364a16dd02094 (patch)
treee1ee5457b14c8d4bbd542a07fcd7e7e70723a45c
downloadaur-560f9e4432adba991f318db91bb364a16dd02094.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..098ba8ebcc2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lxqt-openssh-askpass-git
+ pkgdesc = LXQt openssh password prompt
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = http://lxqt.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = liblxqt-git
+ provides = lxqt-openssh-askpass
+ conflicts = lxqt-openssh-askpass
+ source = git+https://github.com/lxde/lxqt-openssh-askpass.git
+ sha256sums = SKIP
+
+pkgname = lxqt-openssh-askpass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cd2e55e3ea6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=lxqt-openssh-askpass
+pkgname=$_pkgname-git
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="LXQt openssh password prompt"
+arch=("i686" "x86_64")
+url="http://lxqt.org"
+license=("GPL2")
+depends=("liblxqt-git")
+makedepends=("git" "cmake")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lxde/$_pkgname.git")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}