summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Littley2017-11-13 20:54:20 +0000
committerSamuel Littley2017-11-13 20:55:27 +0000
commit561934b8eae0ff2e7ea3f4a44a6b1d654abc6bac (patch)
treeae03e8f2f9953ba382b51bd44e8031a43a8623a0
downloadaur-561934b8eae0ff2e7ea3f4a44a6b1d654abc6bac.tar.gz
Add PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 26 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50e22d79fdb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = create-react-native-app
+ pkgdesc = Bootstrapping tool for React Native
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/react-community/create-react-native-app
+ arch = any
+ license = BSD-3-Clause
+ makedepends = npm
+ depends = nodejs
+
+pkgname = create-react-native-app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c08881888a83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+# Maintainer: samuellittley <samuel.littley@toastwaffle.com>
+pkgname=create-react-native-app
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Bootstrapping tool for React Native"
+arch=(any)
+url="https://github.com/react-community/create-react-native-app"
+license=('BSD-3-Clause')
+depends=('nodejs')
+makedepends=('npm')
+
+package() {
+ npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+}