summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdgard Castro2017-02-21 17:13:51 -0300
committerEdgard Castro2017-02-21 17:13:51 -0300
commit56246632eca14635ec9d57d163b6939fa2ed3cc8 (patch)
tree9a83995343f8269f67f02f856c9f8f5c74f506cc
downloadaur-56246632eca14635ec9d57d163b6939fa2ed3cc8.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..029622be3dd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnome-shell-extension-panel-osd-git
+ pkgdesc = Place gnome-shell notifications under the panel instead of above the message-tray. (git version)
+ pkgver = r113.c33034a
+ pkgrel = 1
+ url = https://github.com/jenslody/gnome-shell-extension-panel-osd
+ arch = any
+ license = GPL3
+ makedepends = gnome-common
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = intltool
+ makedepends = pkg-config
+ depends = gnome-shell
+ provides = gnome-shell-extension-panel-osd
+ conflicts = gnome-shell-extension-panel-osd
+ source = git+https://github.com/jenslody/gnome-shell-extension-panel-osd.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-panel-osd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98f31d350925
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Edgard Castro <castro@edgard.org>
+# Contributor: Carl George < arch at cgtx dot us >
+# Contributor: Tamás Barta < barta dot tamas dot d at gmail dot com >
+
+pkgname=gnome-shell-extension-panel-osd-git
+pkgver=r113.c33034a
+pkgrel=1
+pkgdesc='Place gnome-shell notifications under the panel instead of above the message-tray. (git version)'
+arch=(any)
+_githubname=gnome-shell-extension-panel-osd
+_githubowner=jenslody
+url="https://github.com/${_githubowner}/${_githubname}"
+license=(GPL3)
+depends=('gnome-shell')
+makedepends=("gnome-common" "automake" "autoconf" "intltool" "pkg-config")
+source=("git+https://github.com/${_githubowner}/${_githubname}.git")
+sha256sums=('SKIP')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+
+
+pkgver() {
+ cd "${srcdir}/${_githubname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_githubname}"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_githubname}"
+ make DESTDIR="$pkgdir" install
+}