summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2018-08-27 10:48:03 -0700
committerDonald Webster2018-08-27 10:48:03 -0700
commit562eb510e64706996fa40db932e599e87729f14c (patch)
tree969f653f668f1563dd868904cd55ba919ed0ec4d
downloadaur-562eb510e64706996fa40db932e599e87729f14c.tar.gz
Initial package for sonarr phantom branch.
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD47
-rw-r--r--sonarr.service17
-rw-r--r--sonarr.sysusers2
-rw-r--r--sonarr.tmpfiles5
6 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..beace4c316ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = sonarr-phantom
+ pkgdesc = TV download automation for usenet and torrents.
+ pkgver = 3.0.0.219
+ pkgrel = 1
+ url = http://www.sonarr.tv
+ arch = any
+ license = GPL3
+ depends = mono
+ depends = libmediainfo
+ depends = sqlite
+ optdepends = sabnzbd: usenet downloader
+ optdepends = nzbget: usenet downloader
+ optdepends = transmission-cli: torrent downloader (CLI and daemon)
+ optdepends = transmission-gtk: torrent downloader (GTK+)
+ optdepends = transmission-qt: torrent downloader (Qt)
+ optdepends = deluge: torrent downloader
+ optdepends = rtorrent: torrent downloader
+ optdepends = jackett: torrent indexer proxy
+ provides = sonarr
+ conflicts = sonarr
+ conflicts = sonarr-develop
+ source = http://download.sonarr.tv/v3/phantom/3.0.0.219/Sonarr.phantom.3.0.0.219.linux.tar.gz
+ source = sonarr.service
+ source = sonarr.sysusers
+ source = sonarr.tmpfiles
+ sha256sums = b0e7b41794597e850bb622c693e2013892e035f279ce7e23236b52e589fc1160
+ sha256sums = c177024bdf5c8c0e42a866cb0509e6130e2bb79a14c7e91556e42f8b18e37bd5
+ sha256sums = cc3c69f719fa64335f4c5b41b2588f1ec56865fb2202f5919d3668b50b8f398e
+ sha256sums = a436a979ca3a9e78bdc410bd0027d97956bfa8d2d4f2b7bdf3f7d2ed199dd6a8
+
+pkgname = sonarr-phantom
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e570bc49abe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.gz
+*.log
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc1c79492836
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+# Contributor:: Justin Dray <justin@dray.be>
+# Contributor:: Daniel Egeberg <daniel.egeberg@gmail.com>
+
+pkgname="sonarr-phantom"
+pkgver="3.0.0.219"
+pkgrel=1
+pkgdesc="TV download automation for usenet and torrents."
+arch=(any)
+url="http://www.sonarr.tv"
+license=('GPL3')
+depends=('mono' 'libmediainfo' 'sqlite')
+optdepends=('sabnzbd: usenet downloader'
+ 'nzbget: usenet downloader'
+ 'transmission-cli: torrent downloader (CLI and daemon)'
+ 'transmission-gtk: torrent downloader (GTK+)'
+ 'transmission-qt: torrent downloader (Qt)'
+ 'deluge: torrent downloader'
+ 'rtorrent: torrent downloader'
+ 'jackett: torrent indexer proxy')
+
+provides=('sonarr')
+conflicts=('sonarr' 'sonarr-develop')
+
+source=("http://download.sonarr.tv/v3/phantom/${pkgver}/Sonarr.phantom.${pkgver}.linux.tar.gz"
+ "sonarr.service"
+ "sonarr.sysusers"
+ "sonarr.tmpfiles")
+
+noextract=()
+sha256sums=('b0e7b41794597e850bb622c693e2013892e035f279ce7e23236b52e589fc1160'
+ 'c177024bdf5c8c0e42a866cb0509e6130e2bb79a14c7e91556e42f8b18e37bd5'
+ 'cc3c69f719fa64335f4c5b41b2588f1ec56865fb2202f5919d3668b50b8f398e'
+ 'a436a979ca3a9e78bdc410bd0027d97956bfa8d2d4f2b7bdf3f7d2ed199dd6a8')
+
+package() {
+ cd "$srcdir"
+
+ install -d -m 755 "${pkgdir}/var/lib/sonarr"
+
+ install -d -m 755 "${pkgdir}/usr/lib/sonarr"
+ cp -dpr --no-preserve=ownership "${srcdir}/NzbDrone/"* "${pkgdir}/usr/lib/sonarr"
+
+ install -D -m 644 "${srcdir}/sonarr.sysusers" "${pkgdir}/usr/lib/sysusers.d/sonarr.conf"
+ install -D -m 644 "${srcdir}/sonarr.service" "${pkgdir}/usr/lib/systemd/system/sonarr.service"
+ install -D -m 644 "${srcdir}/sonarr.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/sonarr.conf"
+}
diff --git a/sonarr.service b/sonarr.service
new file mode 100644
index 000000000000..17377eb7b0c4
--- /dev/null
+++ b/sonarr.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=Sonarr Service
+After=network.target
+
+[Service]
+User=sonarr
+Group=sonarr
+ExecStart=/usr/bin/mono /usr/lib/sonarr/NzbDrone.exe -nobrowser -data=/var/lib/sonarr
+Type=simple
+TimeoutStopSec=20
+
+# Lets built in updater work well.
+Restart=on-failure
+KillMode=process
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sonarr.sysusers b/sonarr.sysusers
new file mode 100644
index 000000000000..bd3a457f32b7
--- /dev/null
+++ b/sonarr.sysusers
@@ -0,0 +1,2 @@
+u sonarr - - /var/lib/sonarr
+g sonarr -
diff --git a/sonarr.tmpfiles b/sonarr.tmpfiles
new file mode 100644
index 000000000000..f77f9671d2b2
--- /dev/null
+++ b/sonarr.tmpfiles
@@ -0,0 +1,5 @@
+# Override this file with a modified version in /etc/tmpfiles.d/
+d /var/lib/sonarr 0755 sonarr sonarr
+Z /var/lib/sonarr - sonarr sonarr
+Z /usr/lib/sonarr - sonarr sonarr
+L /var/log/sonarr - - - - /var/lib/sonarr/logs/