summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2021-06-18 10:03:46 +0100
committerLeonidas Spyropoulos2021-06-18 10:03:46 +0100
commit563f6d07d88c84188e0a88206eee35fa7be10d42 (patch)
tree97967750a021e0d8bb01b6fa1801b98965ca9ac8
parentdd549ad48ada31550549c5f45b54028c557c6e44 (diff)
downloadaur-563f6d07d88c84188e0a88206eee35fa7be10d42.tar.gz
upgpkg: vim-youcompleteme-git r2813.4df6f35f-1
Review changes to add submodules to source array and call python compile once
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eee796f0056..af55f8b2a8d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,6 +26,8 @@ pkgbase = vim-youcompleteme-git
optdepends = jdtls: Java semantic completion
optdepends = abseil-cpp: if setting _use_system_abseil ON
source = git+https://github.com/ycm-core/YouCompleteMe.git
+ source = git+https://github.com/ycm-core/ycmd.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = vim-youcompleteme-git
diff --git a/PKGBUILD b/PKGBUILD
index c7ccb811a047..1e563d8d70cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,13 +58,17 @@ optdepends=(
'jdtls: Java semantic completion'
'abseil-cpp: if setting _use_system_abseil ON')
if [[ ${_use_system_clang} == "ON" ]]; then
- source=(git+https://github.com/ycm-core/YouCompleteMe.git)
- sha256sums=('SKIP')
+ source=(git+https://github.com/ycm-core/YouCompleteMe.git
+ git+https://github.com/ycm-core/ycmd.git)
+ sha256sums=('SKIP'
+ 'SKIP')
else
source=(git+https://github.com/ycm-core/YouCompleteMe.git
+ git+https://github.com/ycm-core/ycmd.git
clangd-12.0.0.tar.bz2::https://github.com/ycm-core/llvm/releases/download/12.0.0/clangd-12.0.0-x86_64-unknown-linux-gnu.tar.bz2
libclang-12.0.0.tar.bz2::https://github.com/ycm-core/llvm/releases/download/12.0.0/libclang-12.0.0-x86_64-unknown-linux-gnu.tar.bz2)
sha256sums=('SKIP'
+ 'SKIP'
'0bb712b8d2a2d6861ea28b11167fc01c21336e5bce8682caab60257e32d9bba1'
'dc7b08d63fcf504fdbcfc5b96c446beee8ee79dc96e8d315666b20030c41e29a')
fi
@@ -76,7 +80,9 @@ pkgver() {
prepare() {
cd "${srcdir}"/YouCompleteMe || exit
+ # TODO refer these submodules into the source array
git submodule init third_party/ycmd
+ git config submodule.ycmd.url "$srcdir"/ycmd
git submodule update third_party/ycmd
rm -rf "${srcdir}"/YouCompleteMe/third_party/ycmd/cpp/pybind11 || exit
@@ -167,6 +173,5 @@ package() {
find "${pkgdir}" \( -name .git -or -name 'test*' -or -name 'run_tests.py' \) -exec rm -fr {} +
- python -m compileall -d /usr/share/vim/vimfiles "${pkgdir}/usr/share/vim/vimfiles"
python -O -m compileall -d /usr/share/vim/vimfiles "${pkgdir}/usr/share/vim/vimfiles"
}