summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2018-09-29 13:13:31 +0200
committerJean-Marc Lenoir2018-09-29 13:13:31 +0200
commit565903262bc5c51100df480eeeb9aba789e2662b (patch)
treec19d389d6a973ad290eec57433464831fed8244f
parente0ab07cab11177199c84b8df87786993ff5fbc32 (diff)
downloadaur-565903262bc5c51100df480eeeb9aba789e2662b.tar.gz
Add vmAutoStart.xml in the package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--unlocker.py42
-rw-r--r--vmAutoStart.xml9
4 files changed, 24 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab9a3bdc6dc6..1d7432e62c35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = vmware-workstation11
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 11.1.4
- pkgrel = 3
+ pkgrel = 4
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
license = custom
makedepends = sqlite
makedepends = python2
- makedepends = python2-six
makedepends = unzip
depends = dkms
depends = ncurses5-compat-libs
@@ -50,6 +49,7 @@ pkgbase = vmware-workstation11
source = datastores.xml
source = environments.xml
source = proxy.xml
+ source = vmAutoStart.xml
source = vmware-hostd-certificates.service
source = vmware-hostd.service
source = vmware-networks-configuration.service
@@ -72,6 +72,7 @@ pkgbase = vmware-workstation11
sha256sums = 04375658fed0cad4a18d5da1589d4dc1e5171753891ecaadd05f3c3e50c8156f
sha256sums = f8ab8cb8314e2b82e69ea3c571be04540ce613630808d949c20cc2edef27f77d
sha256sums = 3c802523606184a5e8ebbe931d9c6c70d83ff8c6833b9f48aa264f0bd5a18a88
+ sha256sums = ad522a8cbc6103134ce5e677a01b503cd21875cbceb37bd13fd870ebd9ad0e6d
sha256sums = f9440479f3ae5ad0a39bba3150276627878bf83d6879444fb327c53a1dbb5a4d
sha256sums = 70301aa4eff4f42d7d39b276445dc7d8f44b8a0e184775e8a9e3055bb9d8590a
sha256sums = e3812b78158672c7d96b6a58877681462f3fbdfe99a948b32c80c755c8682450
@@ -82,7 +83,7 @@ pkgbase = vmware-workstation11
sha256sums = d1aae68a0864d4483039302931b8a571b2c660706d1c7a7572bd9d6fdc099c37
sha256sums = 7523a9ddd5f6dd00202a8928610a41d135a04497c64ddd2b88fbb155d7a37543
sha256sums = 09711e59f708576d2fb09c464ebbb52806cb7f850cb3d5bbeea634fa58fb6c86
- sha256sums = b739b0c99fb20dc44838ce137e254773b7be051f327eb67fd8cb1342a3ecf344
+ sha256sums = cb9ecff2d9210ea0022d5ac1b2c274dba0ec9b79c031386627f2a668913e1a38
pkgname = vmware-workstation11
diff --git a/PKGBUILD b/PKGBUILD
index 7c490beb939d..ea2fe7791886 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation11
pkgver=11.1.4
_buildver=3848939
_pkgver=${pkgver}_${_buildver}
-pkgrel=3
+pkgrel=4
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -78,6 +78,7 @@ source=(
'datastores.xml'
'environments.xml'
'proxy.xml'
+ 'vmAutoStart.xml'
'vmware-hostd-certificates.service'
'vmware-hostd.service'
@@ -104,6 +105,7 @@ sha256sums=(
'04375658fed0cad4a18d5da1589d4dc1e5171753891ecaadd05f3c3e50c8156f'
'f8ab8cb8314e2b82e69ea3c571be04540ce613630808d949c20cc2edef27f77d'
'3c802523606184a5e8ebbe931d9c6c70d83ff8c6833b9f48aa264f0bd5a18a88'
+ 'ad522a8cbc6103134ce5e677a01b503cd21875cbceb37bd13fd870ebd9ad0e6d'
'f9440479f3ae5ad0a39bba3150276627878bf83d6879444fb327c53a1dbb5a4d'
'70301aa4eff4f42d7d39b276445dc7d8f44b8a0e184775e8a9e3055bb9d8590a'
@@ -128,7 +130,6 @@ _vmware_fusion_ver=7.1.3_3204469
makedepends+=(
python2
- python2-six
unzip
)
@@ -138,7 +139,7 @@ source+=(
)
sha256sums+=(
'09711e59f708576d2fb09c464ebbb52806cb7f850cb3d5bbeea634fa58fb6c86'
- 'b739b0c99fb20dc44838ce137e254773b7be051f327eb67fd8cb1342a3ecf344'
+ 'cb9ecff2d9210ea0022d5ac1b2c274dba0ec9b79c031386627f2a668913e1a38'
)
_fusion_isoimages=(darwin)
@@ -291,7 +292,7 @@ package() {
install -Dm 644 vmware-installer/bootstrap "$pkgdir/etc/vmware-installer/bootstrap"
install -Dm 644 "$srcdir/vmware-vix-bootstrap" "$pkgdir/etc/vmware-vix/bootstrap"
- for hostd_file in config datastores environments proxy; do
+ for hostd_file in config datastores environments proxy vmAutoStart; do
install -Dm 644 "$srcdir/$hostd_file.xml" "$pkgdir/etc/vmware/hostd/$hostd_file.xml"
done
diff --git a/unlocker.py b/unlocker.py
index 94d29e0964d3..2787e65d689e 100644
--- a/unlocker.py
+++ b/unlocker.py
@@ -44,9 +44,7 @@ Offset Length Struct Type Description
from __future__ import print_function
import codecs
import os
-import six
import struct
-import subprocess
import sys
if sys.version_info < (2, 7):
@@ -56,6 +54,7 @@ if sys.version_info < (2, 7):
# Setup imports depending on whether IronPython or CPython
if sys.platform == 'win32' \
or sys.platform == 'cli':
+ # noinspection PyUnresolvedReferences
from _winreg import *
@@ -231,7 +230,7 @@ def patchsmc(name, sharedobj):
# Read file into string variable
vmx = f.read()
- print('File: ' + name)
+ print('File: ' + name + '\n')
# Setup hex string for vSMC headers
# These are the private and public key counts
@@ -349,6 +348,7 @@ def patchvmkctl(name):
print('smcPresent Patched: ' + name)
+# noinspection PyUnresolvedReferences
def main():
# Work around absent Platform module on VMkernel
if os.name == 'nt' or os.name == 'cli':
@@ -356,19 +356,11 @@ def main():
else:
osname = os.uname()[0].lower()
- vmwarebase = ''
- libvmkctl32 = ''
- libvmkctl64 = ''
+ # vmwarebase = ''
vmx_so = False
# Setup default paths
- if osname == 'darwin':
- vmx_path = '/Applications/VMware Fusion.app/Contents/Library/'
- vmx = joinpath(vmx_path, 'vmware-vmx')
- vmx_debug = joinpath(vmx_path, 'vmware-vmx-debug')
- vmx_stats = joinpath(vmx_path, 'vmware-vmx-stats')
-
- elif osname == 'linux':
+ if osname == 'linux':
vmx_path = '/usr/lib/vmware/bin/'
vmx = joinpath(vmx_path, 'vmware-vmx')
vmx_debug = joinpath(vmx_path, 'vmware-vmx-debug')
@@ -379,15 +371,6 @@ def main():
else:
vmwarebase = '/usr/lib/vmware/lib/libvmwarebase.so.0/libvmwarebase.so.0'
- elif osname == 'vmkernel':
- vmx_path = os.path.dirname(os.path.abspath(__file__))
- vmx = joinpath(vmx_path, '/unlocker/bin/vmx')
- vmx_debug = joinpath(vmx_path, '/unlocker/bin/vmx-debug')
- vmx_stats = joinpath(vmx_path, '/unlocker/bin/vmx-stats')
- vmx_so = True
- libvmkctl32 = joinpath(vmx_path, '/unlocker/lib/libvmkctl.so')
- libvmkctl64 = joinpath(vmx_path, '/unlocker/lib64/libvmkctl.so')
-
elif osname == 'windows':
reg = ConnectRegistry(None, HKEY_LOCAL_MACHINE)
key = OpenKey(reg, r'SOFTWARE\Wow6432Node\VMware, Inc.\VMware Workstation')
@@ -409,20 +392,7 @@ def main():
patchsmc(vmx_stats, vmx_so)
# Patch vmwarebase for Workstation and Player
- # Not required on Fusion or ESXi as table already has correct flags
- if vmwarebase != '':
- patchbase(vmwarebase)
- else:
- pass
-
- # Patch libvmkctl to return Apple SMC present
- if osname == 'vmkernel':
- # Patch ESXi 6.0 and 6.5 32 bit .so
- patchvmkctl(libvmkctl32)
-
- # Patch ESXi 6.5 64 bit .so
- if os.path.isfile(libvmkctl64):
- patchvmkctl(libvmkctl64)
+ patchbase(vmwarebase)
if __name__ == '__main__':
diff --git a/vmAutoStart.xml b/vmAutoStart.xml
new file mode 100644
index 000000000000..422da117572b
--- /dev/null
+++ b/vmAutoStart.xml
@@ -0,0 +1,9 @@
+<ConfigRoot>
+ <SystemDefaults>
+ <_type>vim.host.AutoStartManager.SystemDefaults</_type>
+ <startDelay>120</startDelay>
+ <stopAction>PowerOff</stopAction>
+ <stopDelay>120</stopDelay>
+ <waitForHeartbeat>false</waitForHeartbeat>
+ </SystemDefaults>
+</ConfigRoot> \ No newline at end of file