summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2024-01-06 17:51:35 +0100
committerMagnus Boman2024-01-06 17:51:35 +0100
commit5675da6caa1a06ac13e66c63d5868494fdfc0e4f (patch)
tree396b84e3a820d0208486b855d2491f5d64e79463
parent9898794c55611ab840922fcff1c05d8591779bb5 (diff)
downloadaur-5675da6caa1a06ac13e66c63d5868494fdfc0e4f.tar.gz
upgpkg: yt-dlp-git 2023.12.30.r5.gb695127-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbdde1d3431a..9d3c8ea11a24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = yt-dlp-git
pkgdesc = A youtube-dl fork with additional features and fixes (git)
- pkgver = 2023.07.06.r143.g5fccabac2
+ pkgver = 2023.12.30.r5.gb695127
pkgrel = 1
url = https://github.com/yt-dlp/yt-dlp
arch = any
license = Unlicense
checkdepends = python-pytest
+ makedepends = pandoc
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
- makedepends = pandoc
makedepends = git
+ depends = python
depends = python-certifi
+ depends = python-requests
optdepends = ffmpeg: for video post-processing
optdepends = rtmpdump: for rtmp streams support
optdepends = atomicparsley: for embedding thumbnails into m4a files
optdepends = aria2: for using aria2 as external downloader
optdepends = python-mutagen: for embedding thumbnail in certain formats
+ optdepends = python-pycryptodome: for decrypting AES-128 HLS streams and various other data
optdepends = python-pycryptodomex: for decrypting AES-128 HLS streams and various other data
optdepends = python-websockets: for downloading over websocket
optdepends = python-brotli: brotli content encoding support
diff --git a/PKGBUILD b/PKGBUILD
index 766e325d9f67..1fa2398c558a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: katt <magunasu.b97@gmail.com>
pkgname=yt-dlp-git
-pkgver=2023.07.06.r143.g5fccabac2
+pkgver=2023.12.30.r5.gb695127
pkgrel=1
pkgdesc='A youtube-dl fork with additional features and fixes (git)'
arch=(any)
url=https://github.com/yt-dlp/yt-dlp
license=(Unlicense)
-depends=(python-certifi)
-makedepends=(python-build python-installer python-setuptools python-wheel pandoc git)
+depends=(python python-certifi python-requests)
+makedepends=(pandoc python-build python-installer python-setuptools python-wheel git)
checkdepends=(python-pytest)
optdepends=('ffmpeg: for video post-processing'
'rtmpdump: for rtmp streams support'
'atomicparsley: for embedding thumbnails into m4a files'
'aria2: for using aria2 as external downloader'
'python-mutagen: for embedding thumbnail in certain formats'
+ 'python-pycryptodome: for decrypting AES-128 HLS streams and various other data'
'python-pycryptodomex: for decrypting AES-128 HLS streams and various other data'
'python-websockets: for downloading over websocket'
'python-brotli: brotli content encoding support'
@@ -29,7 +30,7 @@ source=(git+"${url}".git)
sha256sums=('SKIP')
pkgver() {
- git -C "${pkgname%-git}" describe --long --tags --exclude=nightly | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C "${pkgname%-git}" describe --long --tags --abbrev=7 --exclude=nightly | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {