summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 20:58:16 +0200
committerAntonio Rojas2022-04-01 20:58:16 +0200
commit56798bfcc2455343256b5db358c216c7bc364f2d (patch)
treef50288b03ed0dc202ea56bdc9fe3877916a95692
downloadaur-56798bfcc2455343256b5db358c216c7bc364f2d.tar.gz
import from community
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD38
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90c3c9aa2519
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = xawtv
+ pkgdesc = A simple Xaw-based TV program which uses the bttv driver or video4linux
+ pkgver = 3.107
+ pkgrel = 1
+ url = https://git.linuxtv.org/xawtv3.git
+ arch = x86_64
+ license = GPL
+ makedepends = mesa
+ makedepends = git
+ makedepends = xorgproto
+ depends = aalib
+ depends = v4l-utils
+ depends = libxv
+ depends = libxrandr
+ depends = libgl
+ depends = libdv
+ depends = zvbi
+ depends = libxinerama
+ depends = lirc
+ depends = libxft
+ depends = libxaw
+ depends = xorg-fonts-misc
+ depends = libxxf86vm
+ source = git+https://git.linuxtv.org/cgit.cgi/xawtv3.git#commit=8e3feea862db68d3ca0886f46cd99fab45d2db7c
+ md5sums = SKIP
+
+pkgname = xawtv
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6e7bfd627cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
+# Contributor: Jason Chu <jason@archlinux.org>
+
+pkgname=xawtv
+pkgver=3.107
+pkgrel=1
+pkgdesc="A simple Xaw-based TV program which uses the bttv driver or video4linux"
+arch=('x86_64')
+url="https://git.linuxtv.org/xawtv3.git"
+license=('GPL')
+depends=('aalib' 'v4l-utils' 'libxv' 'libxrandr' 'libgl' 'libdv' 'zvbi' 'libxinerama' 'lirc' 'libxft' 'libxaw' 'xorg-fonts-misc' 'libxxf86vm')
+makedepends=('mesa' 'git' 'xorgproto')
+_commit=8e3feea862db68d3ca0886f46cd99fab45d2db7c
+source=("git+https://git.linuxtv.org/cgit.cgi/xawtv3.git#commit=$_commit")
+md5sums=('SKIP')
+
+pkgver() {
+ cd xawtv3
+ git describe --tags | sed 's/^xawtv-//;s/-/+/g'
+}
+
+prepare() {
+ cd xawtv3
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/xawtv3"
+ CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
+ ./configure --prefix=/usr --disable-motif --disable-quicktime
+ make
+}
+
+package() {
+ cd "${srcdir}/xawtv3"
+ make DESTDIR="${pkgdir}" install
+}